Cannot Install Flashplayer plugin



  • Vivaldi 1.4.589.38 (Stable channel) (64-bit) Revision afa9b018e32575fcd8f8283755a315804ecf0671 OS Linux Blink 537.36 (@afa9b018e32575fcd8f8283755a315804ecf0671) JavaScript V8 5.3.332.47 Flash (Disabled) User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.148 Safari/537.36 Vivaldi/1.4.589.38 Command Line /usr/bin/vivaldi-stable --ppapi-flash-path --ppapi-flash-version --always-authorize-plugins --disable-translate --window-depth=24 --x11-visual-id=33 --wm-user-time-ms=11472546 --flag-switches-begin --flag-switches-end Executable Path /opt/vivaldi/vivaldi Profile Path /home/internetoutlaw/.config/vivaldi/Default ubuntu 16.04 LTS Memory 3.6 Gib Processor AMD Turion(tm) X2 Dual-Core Mobile RM-72 x 2 Graphics Gallium 0.4 on AMD RS780 (DRM 2.43.0, LLVM 3.8.0) OS Type 64-bit Disk 143.4 GB 1. Have tried instructions from Vivaidi Help at https://help.vivaldi.com/article/install-flash-player-for-vivaldi/ several times a. Step 4 " Click download and run the file, after installing the flash player, reopen or restart the browser." is the difficult step as there is no direct way to install the player although it can be downloaded. Fully understand this is not a Vivaldi problem. b. Enabled the “Canonical Partner Repositories” and then tried to install the adobe-flashplugin package. c. Attempt to update results in "most recent version is already installed". However, no flash is displayed at vivaldi://plugins 2. Have tried all applicable suggestions in Forum 3. Have tried http://askubuntu.com/questions/765480/how-can-i-install-the-flash-player-for-chromium-in-ubuntu-16-04 4. Have tried http://askubuntu.com/questions/806250/how-to-manually-install-latest-pepper-flash-onto-chromium 5. Have tried https://launchpad.net/~skunk/+archive/ubuntu/pepper-flash 6. Have tried alternate flash player http://lightspark.github.io/ 7. Have tried http://askubuntu.com/questions/25961/how-do-i-install-a-tar-gz-or-tar-bz2-file 8. Have searched Chrome store for possible players 9. Removed Firefox and ran the cleaner Bleachbit so Firefox could not block any versions of Adobe Flash html5 in Vivaldi will not play flash player for mp3 files Firefox, Chrome and Opera will all play web content (and mp3's) with a flash player Is Vivaldi blocking the Flash plugin as the Browser's About shows "Flash (Disabled)" If pepperflash is recommended, why is it not included? Is it a licensing issue? If so why isn't an alternate player plugin such as Lightspark, which has a free license and is updated, available as an option? At the point of exasperation. Therefore, please advise if there is a possible solution to install a flash player and have it work. Thank you.



  • The flash path in your command line isn't set. Have you tried this suggestion? https://vivaldi.net/en-US/forum/vivaldi-browser-for-linux/15969-flash-on-linux-yet-another-way-to-fix-this#79972



  • I use flash beta 24 from adobe web site. No problems with it and was using it in firefox before. Extract to /usr/lib(64)/chromium/PepperFlash/.
    Obviously, you may need to create the folder.
    You need the 2 main files: libpepflashplayer.so and manifest.json.



  • I think the path paste the Adobe extracted files to for Vivaldi under a Debian linux distro is "/usr/lib/pepperflashplugin-nonfree/" it may be different for different type of linux,

    [Vivaldi search paths for libpepflashplayer.so]
    /opt/google/chrome/PepperFlash/
    /usr/lib/pepperflashplugin-nonfree/
    /usr/lib/PepperFlash/
    /usr/lib/chromium/PepperFlash/
    /usr/lib64/chromium/PepperFlash/
    /usr/lib/pepflashplugin-installer/
    /usr/lib/chromium-browser/PepperFlash/
    /usr/lib64/chromium-browser/PepperFlash/
    
    [Linux distro search paths for libpepflashplayer.so]
    /opt/google/chrome/PepperFlash/libpepflashplayer.so # google
    /usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so # debian/ubuntu
    /usr/lib/PepperFlash/libpepflashplayer.so # arch/slack
    /usr/lib/chromium/PepperFlash/libpepflashplayer.so # openSuse 32-bit
    /usr/lib64/chromium/PepperFlash/libpepflashplayer.so # openSuse 64-bit
    /usr/lib/pepflashplugin-installer/libpepflashplayer.so # ppa:skunk/pepper-flash
    /usr/lib/chromium-browser/PepperFlash/libpepflashplayer.so # rosa/mandriva 32-bit
    /usr/lib64/chromium-browser/PepperFlash/libpepflashplayer.so # rosa/mandriva 64-bit
    

    Pasting the files in the "/usr/lib/pepperflashplugin-nonfree/" worked great for me but your Linux distro may use a different path and just for your info my distro is SolydX 8 which is based on Debian and the XFCE desktop.

    Thanks

    //MODEDIT: corrected Code;
    The forum does not use BBCode tags! Please read http://commonmark.org/help/ for formatting.



  • @luetage That solution is probably becoming obsolete with vivaldi 1.5 as 1) it seems to find the .so file in more locations than before and 2) it no longer checks for the file in the wrapper (but instead in the actual binary?).
    If even vivaldi 1.5 can't find the file, then the --ppapi-flash-path workaround still works, but becomes a bit more complicated because you have to add it from scratch instead of just modifying something that's already in the file.
    I'm not sure when vivaldi 1.5 will be released as stable (I'm sure there's information out there in the vivaldi blog), but it probably won't take long and by then this problem should fix itself for most users.


  • Vivaldi Team

    Install the Official Adobe Flash package:

    sudo add-apt-repository "deb http://archive.canonical.com/ubuntu `lsb_release -sc` partner" 
    sudo apt update
    sudo apt install adobe-flashplugin
    

    If you have Vivaldi older than 1.4.589.41, create a symlink so that it is found:

    sudo mkdir -p /usr/lib/PepperFlash
    sudo ln -fs /usr/lib/adobe-flashplugin/libpepflashplayer.so /usr/lib/PepperFlash/libpepflashplayer.so


  • I THINK flash is now properly working.

    Adobe Flash Player - Version: 23.0.0.205
    Shockwave Flash 23.0 r0
    Name: Shockwave Flash

    Location: /home/__________/.config/google-chrome/PepperFlash/23.0.0.205/libpepflashplayer.so

    Type: PPAPI (out-of-process)
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash .swf
    application/futuresplash FutureSplash Player .spl

    At this time I would like to thank the two experts that were able to actually resolve the issue. They are typical brilliant Russians that have been recruited by US government to help fight cyber crime and finally put an end to the Nigerian spam scam.

    //MODEDIT: Deleted picture with children. Such pictures may violate laws and break Forum Rules.

    Seriously, thanks to all.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.