Flash on linux: Yet another way to fix this



  • So a few days ago something seems to have changed with google chrome, and now libpepflashplayer.so seems to be located somewhere else, so apt-get install pepperflashplugin-nonfree no longer works because it can't find it. After doing a lot of reading, googling and testing, I have reached to the conclusion that nothing you can find on the internet works. I literally tried everything I could find. So after some more reading, someone* mentioned that there is some information in help->about and this is when the pieces all came together to form a solution: It didn't give me the information I wanted, which is the path where vivaldi searches for the flash plugin, but it gave me a critical piece of information: Vivaldi starts with a series of commandline flags. Why though? I can type vivaldi into the terminal and it still gets commandline flags. Then it hit me that the vivaldi executable might not be the actual vivaldi binary. And indeed, it was actually... a dynamic link to a dynamic link to a dynamic link to a bash script. <sarcasm>Yeah, a truly elegant solution</sarcasm>. So, what I did was open said bash file, scroll through it, and indeed I ended up finding what I wanted. The actual fix: 1. Run (sudo) apt-get install adobe-flashplugin 2. Open /opt/vivaldi/vivaldi (as root or using sudo) 3. find the long block of if-else-statements where the variable FLASH_PATH is set 4. either add your own elseif to the list or just remove all of it and set FLASH_PATH to /usr/lib/adobe-flashplugin/libpepflashplayer.so Restart vivaldi and hope for the best In case it doesn't work, make sure that libpepflashplayer.so is actually located in that directory on your system EDIT: * https://vivaldi.net/en-US/forum/vivaldi-browser/15854-flash-ppapi-installation-not-recognized (scroll down a bit) EDIT2: Best way to check if it worked is to check help->about->Flash



  • this was working for me with pepperflash until today with 1.5.652.8 (Official Build) dev (64-bit). now it doesn't show up in vivaldi://plugins anymore. still shows up in firefox fine.



  • @marcosmobley It seems they have changed the vivaldi executable to no longer handle searching for the flash player plugin. My guess is that there's either a list of directories to seearch hardcoded into the executable now. In my case, vivaldi automatically found the file in /usr/lib/adobe-flashplugin/libpepflashplayer.so. It doesn't seems like there is any config file where this can be changed either, which is kind of sad to be honest.
    I just tested some things, and it turns out the vivaldi binary still takes the --ppapi-flah-paht flag, so you can just modify the executable, scroll to the bottom where the vivaldi binary is actually executed exec -a "$0" "$HERE/vivaldi-bin" --user-data-dir= ... and add this flag somewhere after the "$HERE/vivaldi-bin" part and it should find the library again.

    If any vivaldi developer reads this: Guys, please make the configuration files more transparent!


  • Vivaldi Team

    Install the Official Adobe Flash package:

    sudo add-apt-repository "deb http://archive.canonical.com/ubuntu `lsb_release -sc` partner" 
    sudo apt update
    sudo apt install adobe-flashplugin
    

    If you have Vivaldi older than 1.4.589.41, create a symlink so that it is found:

    sudo mkdir -p /usr/lib/PepperFlash
    sudo ln -fs /usr/lib/adobe-flashplugin/libpepflashplayer.so /usr/lib/PepperFlash/libpepflashplayer.so


  • @ruario said in Flash on linux: Yet another way to fix this:

    Install the Official Adobe Flash package:

    sudo add-apt-repository "deb http://archive.canonical.com/ubuntu `lsb_release -sc` partner" 
    sudo apt update
    sudo apt install adobe-flashplugin
    

    If you have Vivaldi older than 1.4.589.41, create a symlink so that it is found:

    sudo mkdir -p /usr/lib/PepperFlash
    sudo ln -fs /usr/lib/adobe-flashplugin/libpepflashplayer.so /usr/lib/PepperFlash/libpepflashplayer.so
    

    I had installed this and installed chrome, chromium and still flash player doesn't work.
    Is there's any working solution for vivaldi?



  • @intel
    What does vivaldi://plugins show you.
    For me, on Ubuntu 16.04....
    0_1487786898286_173.jpg

    glen@Xenial:~$ apt policy adobe-flashplugin
    adobe-flashplugin:
      Installed: 1:20170214.1-0ubuntu0.16.04.1
      Candidate: 1:20170214.1-0ubuntu0.16.04.1
      Version table:
     *** 1:20170214.1-0ubuntu0.16.04.1 500
            500 http://archive.canonical.com/ubuntu xenial/partner amd64 Packages
            100 /var/lib/dpkg/status
    


  • @CantankRus It doesn't show flash player at all !0_1487788912377_Screenshot from 2017-02-22 20-41-32.png



  • @intel said in Flash on linux: Yet another way to fix this:

    @CantankRus It doesn't show flash player at all !

    ...and the terminal command apt policy adobe-flashplugin
    What distro are you using by the way?


  • Vivaldi Translator

    @intel
    You're also in Ubuntu right?
    Ubuntu version? 32bit or 64bit?
    Vivaldi version?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.