[SOLVED] Still questions about Flash/ffmpeg



  • Hi, I know there are several threads about Flash on Linux but Flash is broken for me since a few snapshots. Opensuse Leap 42.1 x86_64 CPU Intel T4200 4 GB GPU Intel GN 965 xf86-video-intel 2.99.917-6.1 Vivaldi latest snapshot I have Chrome stable Version 54.0.2840.71 (64-bit) installed and it show me Adobe Flash Player - Version: 23.0.0.185 Shockwave Flash 23.0 r0 which is not the latest and insecure. Speicherort: internal-not-yet-present < mean path Widevine Content Decryption Module - Version: 1.4.8.903 I have a flash version in > /home/user/.config/google-chrome/PepperFlash/23.0.0.205 Vivaldi show Flash 999. path: /usr/lib64/chromium/PepperFlash/libpepflashplayer.so Which I have installed as 23.0.0.205-1.1 Widevine Content Decryption Module - Version: 1.0.123.456 Problem is now Netflix and Maxdome does not work anymore, was fine a few weeks ago. It is a bit hard to explain as non nativ englisch but why: I have three flash installs Chrome use an old one Vivaldi shows nonsence but use the new Vivaldi use the new but does not work I am sorry, it is all a bit scrambled but I no longer look through. Attachments: [img]https://forum.vivaldi.net/uploads/attachments/19298/flash-vivaldi.gif[/img]



  • may help:
    1. Open vivaldi://components
    2. Hit for all these components "Search for Updates"



  • Hi, there are 6 components available but cant be updated:

    Components
    Components (6)
    CRLSet - Version: 3341
    Status - Component not updated
    Check for update
    Origin Trials - Version: 0.0.0.0
    Status - Component not updated
    Check for update
    File Type Policies - Version: 7
    Status - Component not updated
    Check for update
    recovery - Version: 0.0.0.0
    Status - Component not updated
    Check for update
    EV Certs CT whitelist - Version: 7
    Status - Component not updated
    Check for update
    Signed Tree Heads - Version: 195
    Status - Component not updated
    Check for update

    No Flash component is shown in Vivaldi but in Chrome latest Flash plugin is showed. ???
    May I should reset my profile to get a fresh one.

    Thanks for help, mib



  • Hi, deleted profile, uninstalled Chrome and delete Chrome profile.
    Installed Chromium and ffmpeg-chromium.
    Copied libwidevinecdmadapter.so from /usr/lib64/chromium to /opt/vivaldi-snapshot and overwrite the original file.
    The start script "vivaldi-snapshot" is wrong for Suse, corrected to path > /usr/lib64/chromium instead of /usr/lib64/chromium/lib.
    The directory "lib" does not exist.
    All is working now again, puh.

    Cheers, mib


  • Vivaldi Team

    It is just a minor cosmetic issue that it does not display correct on that internal page. The reason for it is that there is no manifest.json in the directory alongside Flash, hence we could not calculate the version without inspecting the binary (which is a slow process and would add to the startup time).

    If you want to check the version number of the Flash you have installed use this link: http://www.adobe.com/software/flash/about/


  • Vivaldi Team

    @mib2berlin said in Still questions about Flash:

    The start script "vivaldi-snapshot" is wrong for Suse, corrected to path > /usr/lib64/chromium instead of /usr/lib64/chromium/lib.

    No, the correct path is indeed /usr/lib64/chromium/lib. The file stored in /usr/lib64/chromium does not provide support for h.264



  • Hi ruario, thanks for reply.
    The problem is there is no lib directory in /usr/lib64/chromium.

    Cheers, mib

    ![0_1478547676138_chromium_lib.gif](Uploading 100%) 0_1478547717111_chromium_lib.png



  • @mib2berlin said in Still questions about Flash:

    Hi ruario, thanks for reply.
    The problem is there is no lib directory in /usr/lib64/chromium.

    Cheers, mib

    ![0_1478547676138_chromium_lib.gif](Uploading 100%) 0_1478547717111_chromium_lib.png

    So make one and copy or symbolically link the files needed into it. Possibly running ldconfig afterwards although it should find them if that lib64 directory is already in the system library path.



  • Hi, add lib dir to chromium and copy several libs to it but Netflix/h.264 still not working.
    A hint from MacUser2525 in another thread solve the problem for me.

    https://forum.vivaldi.net/topic/11933/html5-in-vivaldi-opensuse

    THX, mib


  • Vivaldi Team

    Ok, it seems they change the location after some package update. We have fixed this internally. You will get a fix in the next snapshot and when Vivaldi stable moves to 1.5


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.