Ungültiger Maschinenbefehl



  • Grüße, seit vorletzten Snapshot erhalte ich auf meinem Debian Linux 8 (64Bit) mit 64Bit-Vivaldi Snapshot beim Start nur noch "Ungültiger Maschinenbefehl". Habe danach parallel die stable-version (64Bit) installiert und die läuft problemlos. Bug in Vivaldi oder kann ich da etwas dran drehen? :/ Attachments: [img]https://forum.vivaldi.net/uploads/attachments/30642/Bildschirmfotovom2016-10-2817:33:41.png[/img]



  • Verwendest du beim Starten irgendwelche Parameter? Ist dein OpenGL aktuell?

    Kann ich mit 1.5.648.6 auf Debian 8.6 (Jessie + Backports) x64 nicht feststellen.



  • Nein, weitere Parameter setze ich nicht.
    Ich habe das Startscript bearbeitet, dahingehend, dass ich den Browser als root starten kann (bitte keine Diskussion, das hat seine Gründe).
    Habe dazu die Parameter –user-data-dir --no-sandbox hinzugefügt. Siehe Anhang.

    Ich hab es mit einem Debian 8.6 laufen; alle Pakete sind aktuell per stable.
    Attachments:



  • Bis du so ein blutiger Linux-Anfänger oder nur ein bisschen müde? :P Du solltest 0xCAFFEE zu dir nehmen oder ein bisschen 0xDEADBEEF.

    @kill0rz:

    Ich habe das Startscript bearbeitet, (…)
    Habe dazu die Parameter –user-data-dir --no-sandbox hinzugefügt.

    So!? –user-data-dir --no-sandbox
    Der Schalter –user-data-dir ohne ein Verzeichnis ist schlichtweg Unfug!
    Setz' doch bitte mal ein gültiges Verzeichnis mit rein.
    Please read the fine manual: https://www.chromium.org/user-experience/user-data-directory

    Ansonsten, was passiert denn wenn du in der shell folgendes zwecks neuem Testprofil machst:
    cd
    mkdir VIVTEST
    vivaldi-snapshot --user-data-dir ~/VIVTEST/

    Immer noch "ungültiger Maschinenbefehl"?



  • @Gwen-Dragon:

    Der Schalter –user-data-dir ohne ein Verzeichnis ist schlichtweg Unfug!

    Ich meine nicht ;) Ohne diesen, nicht gesetzten Parameter startet Vivaldi nicht als root. Ich vermute mal, dass dann irgendein Standardpfad greift und den im Startscript überschreibt. Funktioniert auf jeden Fall
    Wenn es eine elegantere Möglichkeit gibt, dann gerne her damit ;) Nein, es kein anderer User :P

    Auf mit dem letzten Release von heute und dem temporären Profil geht es leider nicht; kommt aufs selbe raus :(

    Hatte noch vergessen zu erwähnen, dass ein apt install –reinstall vivaldi-snapshot auch nicht geholfen hat. Purgen möchte ich es ungern :P
    Attachments:



  • Warum bei dir auf Debian 8 "ungültiger Maschinenbefehl" kommt, ist für mich nicht nachvollziehbar.
    Nachdem ich xhost umgetellt habe, startet mein vivaldi-snapshot auch als root mit –user-data-dir.



  • Hm, Mist :(

    vivaldi-stable läuft ohne Probleme. An einer Parallelinstallation kann es nicht liegen, da ich stable erst nach Auftretens des Problems installiert habe.

    Ich versuche dann doch mal einen purge. Etwas anderes fällt mir nicht ein :/



  • 100% cleane Installation, alle Daten inkl. config vorher gelöscht, nichts modifiziert - trotzdem :(
    Attachments:



  • Ich kann jetzt nur rumraten.
    Problem mit SELinux oder sonstwelchen Härtungen deines OS?
    Was ist denn das für ein Fenstermanager?



  • An der Konfiguration des Systems hat sich nichts geändert; nur Vivaldi wurde auf den letzten Stand gebracht ;)

    Ich nutze ein Gnome 3.14; uname -a –>
    Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux, falls das noch hilft.

    Macht mich nur stutzig, dass es von jetzt auf gleich kaputt war, ohne mein Zutun. :(



  • Den Kernel hab ich auch.
    Habe jetzt zum Test KDE 4.14.2-5+deb8u1
    kein OpenGL;
    ist ne VM.

    Aber bei mir läuft es.

    [email protected]:~$ 
    [email protected]:~$ xhost +
    access control disabled, clients can connect from any host
    [email protected]:~$ sudo -i
    [email protected]:~# xhost +
    access control disabled, clients can connect from any host
    [email protected]:~# vivaldi-snapshot --user-data-dir --no-sandbox
    

    Vielleicht spinnt dein Grafiktreiber oder dein Sound und Vivaldi crasht.
    Schaust du bitte mal ob dein Xorg-Log irgendwas dazu drin hat? Oder dein syslog aka log/messages?

    Oder deine CPU ist nicht geeignet? Ist bei deienr CPU SSE2 aktiviert?

    cat /proc/cpuinfo | grep flags
    

    Kannst du bitte mal in der Shell für root deine Sprache umschalten auf EN?
    Was steht da als Fehlermeldung beim Start von vivaldi-snapshot? Illegal opcode? Oder was?



  • Erstmal vielen Dank für deine Hilfe :)

    Ich stelle gerade fest, dass der Befehl

    vivaldi-snapshot --user-data-dir --no-sandbox
    ```Vivaldi starten lässt :blink:
    Kein Plan, warum das so geht, aber ohne die Konsolenparameter nicht!
    
    

    cat /proc/cpuinfo | grep flags

    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave lahf_lm arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave lahf_lm arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms

    Der Xorg-Log bleibt leer und in den messages kommen zwei Zeilen:
    
    

    Nov 2 15:41:26 debian kernel: [10391.573991] traps: vivaldi-bin[22799] trap invalid opcode ip:7fbce2b37399 sp:7fff3f60c000 error:0 in vivaldi-bin[7fbce1a62000+6a73000]
    Nov 2 15:41:26 debian kernel: [10391.582701] traps: vivaldi-bin[22790] trap invalid opcode ip:7f4184a8d8bd sp:7ffc38981cb0 error:0 in vivaldi-bin[7f4183a87000+6a73000]

    Das mit der Sprachumstellung sollte damit nicht mehr nötig sein :)
    
    Danke soweit! :)

Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.