Blurred Text



  • I have been using Opera for a long time (actually 12.18) and just gave Vivaldi 1.4.589.38 a chance. OS is Windows 7 64Bit with ClearType=off and FontSmoothing=off. Nevertheless Vivaldi menus are totally blurred. Websites are sometimes halfway readable (like this forum) but mostly not (like e.g. Vivaldi homepage https://vivaldi.net/en-US/) because the fonts look like scrap, see attached snapshot. Is there any solution for Vivaldi to disable ClearType, FontSmoothing or whatever makes the text nearly unreadable? Attachments: [img]https://forum.vivaldi.net/uploads/attachments/87794/vivaldi.png[/img]




  • Moderator

    @Opera12.18:

    I have been using Opera for a long time (actually 12.18) and just gave Vivaldi 1.4.589.38 a chance. OS is Windows 7 64Bit with ClearType=off and FontSmoothing=off. Nevertheless Vivaldi menus are totally blurred. Websites are sometimes halfway readable (like this forum) but mostly not (like e.g. Vivaldi homepage https://vivaldi.net/en-US/) because the fonts look like scrap, see attached snapshot.

    Is there any solution for Vivaldi to disable ClearType, FontSmoothing or whatever makes the text nearly unreadable?

    ENABLE ClearType and text will be readable



  • @TbGbe: Thanks but I could not find in those threads any working solution but only other users which are complaining about the same issue.

    @den_po: Enabling ClearType is of course no option for me. This would make everything on OS level blurry.

    Unfortunately the blurry characters are hurting my eyes that much that it makes Vivaldi totally unusable for me. Any other idea to solve this problem?


  • Moderator

    @Opera12.18:

    @den_po: Enabling ClearType is of course no option for me. This would make everything on OS level blurry.

    OK, enable and setup it.



  • @den_po: This makes all text on OS level blurry, no matter how I configure ClearType. It's independant from PC and monitor.

    Please understand that any font smoothing or whatever hurts my eyes so much that I really cannot use it: Due to the blur, my eyes lose the focus because they try to get the unsharp text into focus. Therefore this is a real no-go for me. Text is only sharp for my eyes, when I see only black and white pixels - no adjacent grey pixels or (even worse) colored sub-pixels.

    BTW: Like Vivaldi, IE11 ignores the OS setting and therefore has exactly the same problem. At work where I unfortunately have to use IE11, I could only fix it by forcing it to use a very strange font named Gulim instead of the font demanded by a website. As a workaround, is it possible to force Vivaldi to use a sharp font like IE11? Unfortunately changing the font preference has no effect.



  • Any idea to solve the issue? Or is using Opera 12.18 (or another browser without font blurring like e.g. FF) the only option?


  • Moderator

    @Opera12.18:

    @den_po: This makes all text on OS level blurry, no matter how I configure ClearType. It's independant from PC and monitor.

    Please understand that any font smoothing or whatever hurts my eyes so much that I really cannot use it: Due to the blur, my eyes lose the focus because they try to get the unsharp text into focus.

    It's called showing off



  • @den_po:

    OK, enable and setup it.

    so that he can choose between different kinds of blurry. very helpful.

    @Opera12.18:

    Any idea to solve the issue? Or is using Opera 12.18 (or another browser without font blurring like e.g. FF) the only option?

    currently not. as discussed in the directwrite thread linked above, there is no solution for vivaldi yet. and looking at the time span since the introduction of this issue, i'm not sure the will be a solution. even though other chromium based products have found ways around the catastrophic default rendering mechanism google has chosen.

    so for now you can use an older vivaldi build from before the chromium version that removed the working font rendering or use firefox (which also uses directwrite, but acts as an example that clear fonts are possible if you know how) or use the ancient opera, which probably still has more security flaws than the last good vivaldi build. so i'd say depending on your comfort level of using an outdated browser: take the old vivaldi or the newest firefox.

    also creating a bug ticket for vivaldi might be a good idea, it's like voting on a fix for this issue.


  • Moderator

    @Mikka:

    @den_po:

    OK, enable and setup it.

    so that he can choose between different kinds of blurry. very helpful.

    Much better than this ugliness

    [attachment=4811]nosmoothing.png[/attachment]
    Attachments:



  • @Opera12.18 Firefox still has better fonts for reading than other browsers, but FWIW this is what I did to get rid of most of the blurry fonts in Vivaldi flags settings.

    1. Disabled Direct Write
    2. Disabled LCD text antialiasing

    then in Win10 I turned on Clear Type Text with a check mark in the box and went thru the 5 font samples so it can average out what I want. Go to "Fonts", Adjust Clear Type Text, put that check mark and look at the sample set up. I think you have to reboot for it to take full effect. I also turned off "unchecked" Smooth Edges of Screen Fonts , in System Properties, Performance options, Visual Effects

    HTH



  • @stpvid1 said in Blurred Text:

    @Opera12.18 Firefox still has better fonts for reading than other browsers, but FWIW this is what I did to get rid of most of the blurry fonts in Vivaldi flags settings.

    1. Disabled Direct Write

    There is no "Disable Direct Write" checkbox anymore.

    @stpvid1 said in Blurred Text:

    then in Win10 I turned on Clear Type Text with a check mark in the box and went thru the 5 font samples so it can average out what I want. Go to "Fonts", Adjust Clear Type Text, put that check mark and look at the sample set up. I think you have to reboot for it to take full effect. I also turned off "unchecked" Smooth Edges of Screen Fonts , in System Properties, Performance options, Visual Effects

    If I did that, everything on OS level would be blurry. Clear type is always a mess, no matter which setting I choose! That's why I switched it off on every computer which I'm using.

    As there is no solution or even a workaround, Vivaldi is at least at the moment totally unusable for me. So I'm going to de-install it. Maybe I will give it a chance again in a year or so.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.