Running vivaldi as different user



  • i couldn't find the answer to this on !so or vivaldi. on windows 10, i installed to default install location from a standard user account by elevating its priviledges. i'm stuck using admin account for now. trying to start program on administrative user desktop as standard user. file explorer will open \appdata\local\vivaldi\vivaldi.exe, starts with program defaults. makes me think im running the program as an administrator. don't want to do that. experimented with command prompt runas /user:[user] vivaldi/vivaldi.exe from multiple directories. is my runas syntax wrong, or is it because of different install location?


  • Moderator

    Why did you elevate privileges?



  • for the install, because i needed to for "sideloading" software. for run, virtualbox gives me problems with cupswrapper if i run it as standard user. i thought i would be admin for short while. got stuck in virtualbox project, taking longer than i thought. i want to keep virtualbox project running, rather not switch users indefinitely. seemed like a practical experiment to start as process as different user privelidge. practical enough to be an excuse for my curiosity anyway. i don't know enough about windows command line.


  • Moderator

    Pretty sure if you install it standalone, all users can run it. In such a case, you would not want to install it in a single user's directory (other non-admin users are barred from access) - but rather in Program Files or Program Files (x86) or even just a dedicated directory on your c: drive.



  • i believe i explained that poorly. i will try again:
    pc has two users. userA (admin), userS (standard). both user profiles are the same person
    userS gets permission from userA to install vivaldi in c:\users\userS\appdata…
    userS configures and uses vivaldi
    userA is logged on, cannot interrupt session processes
    userA wants to run vivaldi as userS, to prevent priviledge escalation vulnerabilities
    userA opens command prompt: runas /user:userS@domain c:\users\userS\appdata\local\vivaldi\vivaldi.exe
    userS PIN entered and command runs
    vivaldi does not run on userA's desktop
    if userA opens vivaldi.exe from file explorer vivaldi opens to default settings

    i thought since vivaldi lost extensions/keybindings/speed dial when opened from file explorer, that the vivaldi process was running under userA, not userS. the linux way to do this is while logged into session under userA:
    userA@pc$ su userS
    [password]
    userS@pc$ vivaldi.exe&


  • Moderator

    Don't know how you would do that in Windows. I'm not aware (though it may well exist) of an ability to run a process or program as an alias.


  • Moderator

    Privelege and User Rights managment is different fromLinux.

    I can start Vivaldi as an other user from DOS box and with desktop shortcut.
    Please try:
    runas /User:OTHERUSER C:\Programs\Vivaldi\Application\vivaldi.exe



  • What are you asking works perfectly for me.

    Just push shift and right click on the vivaldi icon, then chose "run as"

    select the intended user, and provide the credentials when asked by windows

    Vivaldi will start with all the settings stored for that user, not the one you're logged on.



  • gwen-dragon: that was my version, with a different directory. when i retried today, it worked fine.
    solutor: shift+right click is a nifty trick. i was unaware of this.
    today, both strategies worked. when i checked task manager, process was still running as userA. today the difference was that it had the extensions/settings of userS. this made me think it worked today, and i attribute error to my understanding of windows permissions/user processes. thank you both, and my next step is to get my learnin' on regarding windows user process ownership.



  • Check the user with the windows task manager works.

    But you can also check for the actual profile used by vivaldi in V menu/help/about vivaldi or typing vivaldi://about/ in the address field


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.