Blurry UI fonts after reboot!



  • I've been using Vivaldi.1.1.453.59 for ages because every newer version had blurry UI and webpage fonts. I started having other issues with this version so I decided to try the most recent version. I was happy to see that the blurry webpage issue went away but the blurry UI font was still present. I managed to solve it though: after setting Appearance/User Interface Zoom to 105% everything was crisp!!! Until now! Booting up the next day Vivaldi reverted to the blurry UI issue. Any tinkering with the Zoom had no effect whatsoever. How is this possible? The solution is there, because it worked for a short period, but I can't work it out. My desktop DPI is at 100% Windows 7 ultimate 64-bit Vivaldi 1.4.589.38 32-bit



  • You are probably seeing the same problem I had with this latest developer build. Even when you tell the shortcut not to, it's trying to obey windows font scaling in a buggy as hell manner. In my case not only was the rendering blurry, the font kerning – aka the space between letters -- was utterly banjaxed.

    It looked like how Freetype renders fonts in Linux -- something that makes me want to jab out my eyeballs with hot pokers. I CANNOT use Linux as a desktop OS. Sorry, no.

    The solution that worked for me is to add:

    –force-device-scale-factor=1

    after the .exe in the shortcut for launching the program. Find the shortcut, go to its properties, and add that to the end of the "target' area.

    If you have it pinned, right click, and third from bottom (above close and unpin) should be just the name of the program, right click on that and choose properties, and as with a normal shortcut add that command line switch to the target after the .exe

    Cleared it right up here.



  • I CANNOT use Linux as a desktop OS. Sorry, no.

    :DD

    I forgot to mention that I tried the " –force-device-scale-factor=1" shortcut and saw no immediate effect. unfortunately I can't restart my PC right now (download going on) but I'll try it later.

    anyway, thanks for your help, and I'm happy to see at least one person having solved the blurry nightmare! I might revert back to crashy buggy 1.1.453.59



  • nope, didn't help even after rebooting my system.



  • –force-device-scale-factor=1
    This helped in my case, thanks!



  • @Starlight84:

    –force-device-scale-factor=1
    This helped in my case, thanks!

    you lucky bastard! how long have you been using the current version?



  • I see the same fuzziness with the latest build. Compare the two screenshots: Vivaldi vs Opera 41b/rc. The font size difference is not the cause; FF latest, which is similar size as Vivaldi, has the same sharpness as the others.
    Attachments:
    ,



  • This was posted on the blog (I think yesterday in the blogpost: Engine update - Vivaldi Browser snapshot 1.5.638.3):

    [Regression] [Windows] No subpixel rendering when using UI scaling or HiDPI greater than 100%, resulting in perceived blurriness (VB-22377): to work around this enable this flag: vivaldi://flags#enable-use-zoom-for-dsf

    Maybe this helps?



  • thanks but it didn't work. nothing changed. even after adding "–force-device-scale-factor=1" to the shortcut :(



  • From russian topic.

    I found a solution to the problem definition interface! Go to the vivaldi: // flags, look for "Use Blink function to device scaling factor" and set - Enable.



  • @Cerimon:

    From russian topic.

    I found a solution to the problem definition interface! Go to the vivaldi: // flags, look for "Use Blink function to device scaling factor" and set - Enable.

    others suggested it already, unfortunately that flag doesn't help
    thanks for your input though!



  • @internetexplorer

    I was able to clear up my blurry text issue by disabling FontCache



  • @Sobekeus do you mean FontCache scaling in vivaldi://flags? I tried it and nothing changed after relaunch:( thanks anyway


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.