Vivaldi crashing with Kernel Panic on 10.10.5



  • This is what the kernel is logging every other minute. [code]10/15/16 12:01:40.000 PM kernel[0] Vivaldi Helper (map: 0xffffff803d53bc30) triggered DYLD shared region unnest for map: 0xffffff803d53bc30, region 0x7fff90000000->0x7fff90200000. While not abnormal for debuggers, this increases system memory footprint until the target exits.[/code] And this is what it says right after a kernel panic [code] Wed Oct 5 15:45:34 2016 *** Panic Report *** panic(cpu 1 caller 0xffffff8020816f72): Kernel trap at 0x0000000000000000, type 14=page fault, registers: CR0: 0x0000000080010033, CR2: 0x0000000000000000, CR3: 0x0000000010c7c0af, CR4: 0x00000000001626e0 RAX: 0xffffff8042c5c800, RBX: 0xffffff8039ffd600, RCX: 0x0000000000020001, RDX: 0xffffff8039ffd600 RSP: 0xffffff812d6939e8, RBP: 0xffffff812d693a40, RSI: 0x00000000e0000100, RDI: 0xffffff8039ffd600 R8: 0x0000000000000000, R9: 0xffffff7fa12de4c0, R10: 0x000000000000011f, R11: 0x000000000000011f R12: 0x00000000e0000100, R13: 0xffffff8041a34300, R14: 0x00000000e00002c2, R15: 0x0000000000020001 RFL: 0x0000000000010286, RIP: 0x0000000000000000, CS: 0x0000000000000008, SS: 0x0000000000000010 Fault CR2: 0x0000000000000000, Error code: 0x0000000000000010, Fault CPU: 0x1 Backtrace (CPU 1), Frame : Return Address 0xffffff812d693690 : 0xffffff802072ae01 0xffffff812d693710 : 0xffffff8020816f72 0xffffff812d6938d0 : 0xffffff8020833e23 0xffffff812d6938f0 : 0x0 0xffffff812d693a40 : 0xffffff8020cb292d 0xffffff812d693a70 : 0xffffff7fa12b468a 0xffffff812d693aa0 : 0xffffff8020cb27ba 0xffffff812d693b00 : 0xffffff7fa12cf4ff 0xffffff812d693b30 : 0xffffff7fa12ce1d2 0xffffff812d693b50 : 0xffffff8020d01754 0xffffff812d693bb0 : 0xffffff8020cff043 0xffffff812d693cf0 : 0xffffff80207e1487 0xffffff812d693e00 : 0xffffff802072f070 0xffffff812d693e30 : 0xffffff80207139f3 0xffffff812d693e90 : 0xffffff802072437d 0xffffff812d693f10 : 0xffffff802080249a 0xffffff812d693fb0 : 0xffffff8020834646 Kernel Extensions in backtrace: com.apple.iokit.IOUSBFamily(720.4.4)[4ED60649-760E-3E91-9C58-322700847C7E]@0xffffff7fa129f000->0xffffff7fa1303fff dependency: com.apple.iokit.IOPCIFamily(2.9)[1571E932-87CE-3EDF-9A81-19694AFEA29E]@0xffffff7fa0f4d000 BSD process name corresponding to current thread: Vivaldi Boot args: -v Mac OS version: 14F1912 Kernel version: Darwin Kernel Version 14.5.0: Mon Aug 29 21:14:16 PDT 2016; root:xnu-2782.50.6~1/RELEASE_X86_64 Kernel UUID: FE3619E6-270B-34A6-BBD7-BED74EC32693 Kernel slide: 0x0000000020400000 Kernel text base: 0xffffff8020600000 __HIB text base: 0xffffff8020500000 System model name: MacBookPro10,1 (Mac-C3EC7CD22292981F) System uptime in nanoseconds: 6203791779987 last loaded kext at 6202982856025: com.realtek.driver.AppleRTL815XEthernet 1.0.15 (addr 0xffffff7fa35b1000, size 233472) last unloaded kext at 103903981456: com.apple.iokit.IOEthernetAVBController 1.0.3b3 (addr 0xffffff7fa1e37000, size 28672) loaded kexts: //non-apple kernel extensions com.realtek.driver.AppleRTL815XEthernet 1.0.15 com.realtek.driver.AppleRTL815XComposite 1.0.15 org.virtualbox.kext.VBoxNetAdp 5.1.6 org.virtualbox.kext.VBoxNetFlt 5.1.6 org.virtualbox.kext.VBoxUSB 5.1.6 com.logmein.hamachi 1.0 org.virtualbox.kext.VBoxDrv 5.1.6 //apple-extension by non-apple name com.shapeservices.msm.driver.MSMFramebuffer 3.3.2 com.globaldelight.driver.Boom2Device 1.1 //apple-extension by non-apple name com.shapeservices.msm.driver.MSMVideoDevice 3.3.2 //Loads of native apple kernel extensions [...] [/code]


  • Moderator

    Hi. Sorry to hear that you're running into this issue. I'll try to help as best as I can…

    The most likely root cause of your kernel panic is a bug in a third party device driver or kernel extension. I did a quick search on the web and all of your non-Apple kexts have been implicated in panics. However, the backtrace specifically points to com.apple.iokit.IOUSBFamily which indicates that this is a USB-related crash. Vivaldi itself is just a program; it doesn't hook into the operating system, and the worst thing that should ever happen is that Vivaldi crashes. However, the Chromium code (that Vivaldi is built on top of) contains support for WebUSB, and its interaction with OS X's USB services is most likely tickling a bug in some low level kernel code that, in turn, is causing the crash.

    The first thing that I would suggest is to disable Vivaldi's WebUSB support in vivaldi://flags

    Type the following into the Vivaldi address bar: vivaldi://flags#enable-webusb

    Change the flag from Default to Disabled and restart Vivaldi.

    Hopefully, that will stop the crash from being triggered. However, the underlying issues causing the crash will still need to be addressed.

    As for the "Vivaldi Helper (map: 0xffffff803d53bc30) triggered DYLD shared region unnest for map…" errors, I don't think it's related to the crash. I actually don't have any of these in my Console log, and it's possible that it might be extension-related.

    Best of luck, and please let us know if disabling WebUSB helps your situation at all.


  • Moderator

    FYI, I just came across a Chromium bug report pertaining to the "triggered DYLD shared region unnest for map" messages in your log. Here's the link:

    428858 - Lots of "triggered DYLD shared region unnest for map" log messages

    It was closed with a status of "WontFix" as the message, while annoying, was deemed to be harmless by the developers.



  • Macs are very sensitive to what's plugged into them and that could cause a USB related panic. Try removing different peripherals to see if that clears things up. I had it happen to me once. It went away even after I plugged the culprit back in. Just one of those weird things.



  • @xyzzy Sorry for answering this late. For some strange reason I doesn't seem to have got an email notification about activity in this thread. Anyway, thank you for your advice.
    I tried to disable WebUSB just as you suggested. I hope it works.
    The DYLD-thing is still spamming my logs but maybe at least my system won't suddenly crash anymore.

    EDIT: Your link to bugs.chromium was VERY helpful. Seems there are many possibly causes to the DYLD-thing.
    two of which I consider possible ones for my case, too.
    One seems to be a huge amount of 'unsorted' bookmarks resulting from integrating Xmarks.
    The other is a bad Memory DIMM. Memtest will show. I'll post again when I now more.

    @mab52 Thanks for the tip. I'll try that.
    EDIT: Tried it. Crashed my system when I reconnected the USB2Ethernet Bridge, so that definitely was the cause.


  • Moderator

    @Ozymandias42 Hi. Best of luck with your troubleshooting.

    FYI, just to give you some background, I'm using El Capitan 10.11.6, no 3rd-party kexts. I'm also using an application with a user mode USB device driver that had been coded with an older API for backwards compatibility. I NEVER had any stability issues until a few months ago when the application suddenly started crashing randomly, but only when Chrome was also running in the background.... and only after I had upgraded to the version that introduced WebUSB support. Vivaldi also triggered the application crash as well.

    Digging deeper... It looked like the Chromium WebUSB code periodically enumerates USB devices on the system, and this action triggered a chain of events that caused the USB device driver in the application to crash. If the device driver had been implemented as a kernel extension, it would most likely have triggered a kernel panic.

    In my case, temporarily disabling WebUSB alleviated the crash until the root cause could be rectified. Vivaldi was not the actual cause of the problem, it just revealed a problem that was waiting to happen.



  • @xyzzy said in Vivaldi crashing with Kernel Panic on 10.10.5:

    WebUSB

    Christ never heard of that retard idea until now definitely a case of developers having too much time on their hands having solved all the other bugs in a program. Just who the hell ever thought that would be a good idea is beyond me. I guess that must have been a hacking of your computer supporter.

    Edit: BTW where is the setting to disable that I searched in the setting I see nothing there.

    Edit2: To answer my own question set this to disabled restart browser and your good.

    chrome://flags/#enable-experimental-web-platform-features

    https://developers.google.com/web/updates/2016/03/access-usb-devices-on-the-web


  • Moderator

    @MacUser2525 Hi. FYI, the link in your post was authored back in March, 2016, before WebUSB even hit Chrome's Dev channel. A few months later (June?), a new "off switch" flag was added:

    chrome://flags/#enable-webusb

    The corresponding Vivaldi flag is in my initial reply to the original poster.

    Also, FYI, if you want to manage USB Devices, the UI can be accessed by clicking the "Site info" icon in the Vivaldi URL bar and then clicking on "Site settings" in the dropdown. (In Chrome, "Site settings" can be accessed from the "advanced settings" in Preferences...)

    If you're interested in following WebUSB's progress (and ongoing problems/resolutions) here are a few more links:

    https://bugs.chromium.org/p/chromium/issues/detail?id=492204
    https://bugs.chromium.org/p/chromium/issues/list?q=component:Blink>USB

    I don't think this is really a bad feature even though it has caused me a bit of grief. Personally, I'm hoping that this will eventually let me program a Harmony Remote without having to pollute my Mac with Logitech's crappy software.

    (Any further discussion about WebUSB probably merits a thread in the "All platforms" section.)



  • @xyzzy
    Problem has been resolved. Following is a copy of my corresponding post in another thread:

    (Link to other thread:
    https://forum.vivaldi.net/topic/11049/vivaldi-sometimes-crashes-mac-running-osx-10-10-5-when-clicking-on-or-switching-a-tab/2
    )

    I solved the problem for my system.
    See this post: https://forum.vivaldi.net/topic/11518/vivaldi-crashing-with-kernel-panic-on-10-10-5 for a Console.app dump, showing that the culprit has been a driver, the call to which originated from Vivaldi to IOKit (I think)

    Updating those drivers
    namely these two
    com.realtek.driver.AppleRTL815XComposite 1.0.16
    com.realtek.driver.AppleRTL815XEthernet 1.0.16
    to the version stated solved the instability problem.

    Oh and btw. I since have updated to Sierra (macOS 10.12.2)

    P.S.:
    For future reference. compiling a list of non-apple kexts with version-numbers can be accomplished with
    kextfind -not -b -is com.apple -report -b -version
    a warning tho there are a few kexts not named com.apple but belonging to macOS anyway. As rule of thumb I'd recommend not touching anything under /System


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.