Flash stopped working in stable version 1.4.589.38



  • Thanks, your hack is working perfectly. 🙂
    This is event better as I can just use this to launch Vivaldi until the fix gets in the stable version.


  • Moderator

    You have really Google Chrome 54 and newest Pepper Flash player?
    My google-chrome-stable_54.0.2840.59-1_amd64.deb does not hav any pepper-flash.



  • @Gwen-Dragon:

    You have really Google Chrome 54 and newest Pepper Flash player?
    My google-chrome-stable_54.0.2840.59-1_amd64.deb does not hav any pepper-flash.

    Yes, I do, and I have the exact same version of Chrome.
    I didn't installed pepper flash explicitly and it's inside ~/config/google-chrome/, so I suspect it was installed by Chrome.



  • Chrome 54 most likely downloads the plugin from Adobe's site and install it into the user directory, unless it finds it already installed in some system-wide location.



  • I found out "/usr/lib/adobe-flashplugin/libpepflashplayer.so" should be included as a path option in /usr/bin/vivaldi.
    The path is used when you install Flash with adobe-flashplugin package in the Canonical Partners repository for Ubuntu.

    This package can be used without installing Google Chrome and contains both NPAPI and PPAPI plugins.


  • Vivaldi Team

    @riumutu said in Flash stopped working in stable version 1.4.589.38:

    I found out "/usr/lib/adobe-flashplugin/libpepflashplayer.so" should be included as a path option in /usr/bin/vivaldi.

    It will be in 1.4.589.41. For users with older versions create a symlink so that it is found:

    sudo mkdir -p /usr/lib/PepperFlash
    sudo ln -fs /usr/lib/adobe-flashplugin/libpepflashplayer.so /usr/lib/PepperFlash/libpepflashplayer.so
    

    As a reminder for others reading this thread, the easiest way to install the Official Adobe Flash package from the terminal is as follows:

    sudo add-apt-repository "deb http://archive.canonical.com/ubuntu `lsb_release -sc` partner" 
    sudo apt update
    sudo apt install adobe-flashplugin


  • @ruario Thank you very much! 😃



  • @ruario Thank you! As I posted a comment on the blog, I confirmed the update and now Flash works well.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.