[Gelöst] Vivaldi und Startpage



  • Hi, ich nutze Startpage als Suchmaschine in Vivaldi (1.4.589.38 (Stable channel) (64-Bit)). Die Suchmaschine habe ich als Standardsuchmaschine eingerichtet. Nun ist die Standardsprache bei Startpage Englisch, man kann aber in den Einstellungen von Startpage auf Deutsch umstellen und auc noch andere Einstellungen vornehmen. Wenn ich abschließend auf Einstellungen speichern klicke, werden die Einstellungen nur bis zum nächsten Neustart gespeichert. Ich muss also nach jedem Neustart die Einstellungen neu vornehmen. Weiß jemand, wie man die Einstellungen in Vivaldi dauerhaft speichern kann? Gruß paljass



  • Die Einstellungen werden als Cookies gespeichert. Wenn Cookies in Vivaldi gelöscht werden, verliert startpage die Einstellungen. Whitelisting Cookies ist wahrscheinlich die einfachste Option, allerdings in Vivaldi nur mit einer Browser Erweiterung (Extension) möglich. Ich verwende dafür Vanilla Cookie Manager.

    Vivaldi
    Alle Cookies akzeptieren. Diese Einstellung ist nötig damit die Browser Erweiterung das Management übernehmen kann.

    Vanilla Cookie Manager
    In der Whitelist Sektion *.startpage.com hinzufügen.
    In Recommended Usage "Do not auto-delete unwanted Cookies" auswählen und auf "Clear unwanted cookies on startup" setzen.

    Die Whitelist kann je nach Bedarf natürlich erweitert werden.



  • Hi,
    das wars leider noch nicht.
    Vielleicht hätte ich noch erwähnen müssen, dass ich mit Linux mit 18 arbeite !?!

    Edit:
    Das war wohl nix. Hab jetzt noch mal in die Einstellungen geguckt und siehe da - meine Einstellungen sind gespeichert und werden so angezeigt wie eingestellt.
    Das Blöde ist jetzt, dass sich Startpage nen Ei auf die Einstellungen pellt und doch in Englisch sucht :angry:



  • Das sollte keinerlei Unterschied machen. Wenn du die korrekten Einstellung vornimmst, sollte es funktionieren. Habe es mit startpage auf Deutsch getestet – bleibt Deutsch nach Neustart. Vielleicht solltest du nach dem Neustart die Cookies in Vivaldi überprüfen. Wenn startpage keine Cookies gespeichert hat ist etwas schief gelaufen. Ein anderer Tip ist speichern zu klicken in den startpage Einstellungen. Wenn man das nicht tut wird kein Cookie mit deinen Einstellungen gespeichert, also würde auch die Whitelist nicht helfen. Würde mich sehr wundern wenn das auf Linux nicht funktioniert -- solche Dinge sind eigentlich unabhängig vom verwendeten Betriebssystem.



  • So, habe jetzt mal alle Cookies gelöscht, Startpage-Einstellungen geändert und gespeichert.
    Vivaldi hat dann ein Cookie für .startpage.com gespeichert.
    Nach Neustart wird trotzdem wieder Englisch eingestellt und angewendet.
    Den Tipp mit dem Cookie-Manager habe ich selbstverständlichauch beachtet.



  • @luetage:

    Whitelisting Cookies ist wahrscheinlich die einfachste Option, allerdings in Vivaldi nur mit einer Browser Erweiterung (Extension) möglich.

    eigentlich geht Cookiewhitelisting auch nativ mit Vivaldi.
    Ich habe mir ein Lesezeichen dafür angelegt, weil dies (glaub ich) nicht über die normale Einstellungsseite geht (man kann allerdings auch über die Badge vor dem http klicken und unten dann auf Website-Einstellungen gehen, dann kommt man ebenfalls auf) chrome://settings/content
    Dort habe ich sämtliche Cookies geblockt und trage dann entsprechend die Domains ein, für Startpage also [*.]startpage.com
    Danach werden auch bei mir entsprechende Einstellungen nach Neustart des Browsers übernommen



  • @paljass:

    So, habe jetzt mal alle Cookies gelöscht, Startpage-Einstellungen geändert und gespeichert.
    Vivaldi hat dann ein Cookie für .startpage.com gespeichert.
    Nach Neustart wird trotzdem wieder Englisch eingestellt und angewendet.
    Den Tipp mit dem Cookie-Manager habe ich selbstverständlichauch beachtet.

    Habe mir das nochmal angeschaut, und konnte das reproduzieren. Allerdings wird nach dem Neustart die Seite bei mir richtigerweise auf Deutsch eingeblendet. Und zwar nur nach dem Neustart. Vor dem Neustart werden meine Änderungen angezeigt, allerdings ist Startpage immer noch auf Englisch (ganz wie du es beschrieben hast)….

    Ob du nun die Erweiterung verwendest, oder wie oben erwähnt es nativ versuchst, sollte keinen Unterschied machen.

    Verwendest du

    https://startpage.com/do/search?query=%s&cat=web
    ```in den Suchmaschinen Einstellungen? Wenn das auch stimmt weiß ich keinen Rat mehr.


  • Meine getesteten Startpage/Vivaldi-Einstellungen sehen so aus:

    (Optional) Privatsphäre → Cookies → Cookies annehmen → [×] Nur für diese Sitzung
    (Die nächste Einstellung ist nur nötig, wenn in den Vivaldi-Einstellungen keine Cookies angenommen werden.)
    Unter den Inhaltseinstellungen chrome://settings/content
    Ausnahmen verwalten: [.]startpage.com* [Zulassen] → Fertig

    Auf https://www.startpage.com die Sprache auf Deutsch stellen und gegebenenfalls Seite neu laden, damit der Keks gespeichert wird.

    Zusätzlich in Vivaldi die Startseite auf https://www.startpage.com/deu/ ändern
    Und für die Suchmaschine (deutsche Benutzeroberfläche) folgende Adresse verwenden:

    https://www.startpage.com/do/search?language=deutsch&query=%s
    


  • Moin,
    ich hab jetzt mal die von Alexs vorgeschlagene Einstellung (

    https://www.startpage.com/do/search?language=deutsch&query=%s

    ) probiert und es klappt (erstmal) tatsächlich.

    Allen Helfern vielen Dank für ihre Mühe.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.