Will Not Play Youtube or Other Videos In Facebook.

  • I've searched the interest and this site and nothing about this. I cannot watch any videos on Facebook when using Vivaldi, but I can watch the same videos on Facebook if I am in Chrome. What is up with that. I can watch movies if I am within Youtube.com

  • Same issue here^ (running v1.4 on Sierra)

  • Broadly speaking, I have lots of inconsistent behaviors when it comes to playing media. Facebook, Twitter, and even Imgur has some weird behaviors.

  • me too.
    osx 10.10.5 on Macbook Pro 13" Early 2011

    Facebook links to Youtube videos show an error message in the black video box saying "An error ocured. Please try again later." And the video ID. Often the error message is preceeded by a very very short appearance of the video sequence or its advertising equivalent.
    I do not have a YT account, nor a google account.

    Facebook links to Facebook videos just don't start playing, the black video box stays simply black. Same with my own FB-videos and friend's videos.

    In Opera or Safari, Facebook links to any videos play normal.

    Btw: youtube videos on the webpage youtube.com itself also often come up with the error message like on FB. But reloading the page fixes that most of the times. If not, Vivaldi quit and restart fixes the video play on youtube.com

  • Provide links for videos that definitely don't work and information about the gpu and operating system version you are using.
    Check if hardware acceleration works here: vivaldi://gpu

    If hardware acceleration is disabled it's often a problem with unsupported graphics. If that's the case you can either start vivaldi from terminal with this command

    open /Applications/Vivaldi.app --args --ignore-gpu-blacklist
    ```to test it out, or go to vivaldi://flags and enable "Override software rendering list" to make above change permanent. It's the first entry on the site.

  • @luetage

    10.10.5 MBP Early 2011,
    original hardware 100%
    Vivaldi 1.4.589.38
    only Flashplayer current version as extension.

    In normal mode does not display this video when clicking the arrow to start it but only a grey sort of not 100% opaque screen:


    When starting Vivaldi with your commandline, the video displays fine.

    You said either "unsupported graphics" or "hardware acceleration disabled"?
    Is the HW acceleration a setting I choose in Vivaldi prefs?

    I have now set the flag "override" to enable. And restarted. The Facebook-video still plays. Cool 🙂 ! thanks.

    Is it something I need to be concerned about? Putting more strain on my graphics card than I would if I were using Opera or Safari?

  • @silv_ I don't think you need to be concerned about it. It's an issue with all chromium browsers since chrome 53 or 54. You have to do the same change in Google Chrome and in Opera if you want to play videos. Happens mostly with older intel igpus. Are you using HD3000 by any chance?

  • @luetage said in Will Not Play Youtube or Other Videos In Facebook.:


    yes, it's HD3000.

  • @luetage

    Thanks, this worked a treat. I'm also on a Early 2011 MBP HD3000

    vivaldi://flags and enable "Override software rendering list"

  • Moderator

    Oh yes, Intel HD video GPUs are always a pool of nice problems. On Mac and Linux.

  • Seems like many of us have met some problems when playing videos on Vivaldi browser. I installed this browser last month and everything is amazing until last Monday. Some YouTube videos can't be played in HD. While it's OK when I watching them as 320P. If I change the resolution as 1080P or higer resolution, it gave me green screen, while the audio still played well. I searched and got this guide: http://www.videoconverterfactory.com/tips/youtube-green-screen.html I just followed the alternative way this tutorial provide to download the green YouTube movies for offline playback. Lucily, just a few videos got this problem and I still prefer to use Vivaldi browser. By the way, the design of choosing the theme style is awesome.💯

  • These steps helped me with the same issue:
    Open additional settings: vivaldi://flags
    Disable "Hardware-accelerated video decode" option


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.