Scroll Mouse Past Page Top or Bottom



  • In the current Vivaldi build, if I scroll past the top of a webpage or scroll past the bottom of a webpage - it acts as a zoom function. This is not desired, for example if you scroll too far down past the bottom of a page and keep scrolling, it will reduce the size of the page. If you keep scrolling up at the top of a page, it will increase the size of the page. The zoom percentage at the bottom of the screen remains the same, but the image gets bigger or smaller as described above. I tried just about every option in preferences to turn this off if it is an intended feature, but to no avail. In order to rectify this, I installed the developer version of Vivaldi which does not have this problem.



  • I have the same problem and it is really a pity that the great Vivaldi browser is almost unusable for me with this bug.
    On my system (Mac OS X Sierra) it occurs when I scroll very slowly with my external mouse. Then I get this strange zoom effect that also hides navigation buttons at the current web page especially at the edge areas. And I get a strange blur effect with this zoom. Note: I did deactivate dynamic scrolling. Might this be a bug related to this feature?



  • I have this problem too. On some pages it zooms them so large they are unusable and I have found no way to get them to go back to normal. Resetting zoom does nothing, not refreshing the page. if I scroll up to the top and keep scrolling, it will start to shrink it back ever so slowly.

    The previous version of Vivaldi worked fine in El Capitan. When i upgraded to Sierra, it did it. I then upgraded to the newest version and it still does it. It doesn't do it on any other chromium based browser, Firefox or Safari. Since it did it after the upgrade, it must have something to do with Sierra itself. Firefox now has some problems with certain sites rendering them correctly now in Sierra. I do love this browser and hope this can be correctly quickly as I am going through withdrawals! :woohoo:



  • For me this happens in the middle of pages as well, and not necessary at the top/bottom.

    Has anyone opened a bug ticket for this issue? For me this is a showstopper as the browser is pretty much unusable at this point.



  • … also, when the page has been zoomed by the scroll wheel the scroll bar no longer works either.



  • Ah, it actually seems to be fixed in the latest snapshot! :woohoo:



  • This is also happing for me! I thought my mouse was broken.
    1.4.589.38



  • I upgraded to Sierra on Monday, used Vivaldi all day Tuesday with no problems, and began experiencing the zooming issue today (Wednesday). Here is what I've experienced so far:
    [ul]

    • I can scroll down without a problem, but when I attempt to scroll up, the page zooms instead.
    • I can scroll back down to zoom out.
    • The browser's zoom control does not show that the page is zoomed in.
    • The issue only occurs while using the mouse scroll wheel (it doesn't occur when scrolling with keyboard arrows).
    • I downloaded Snapshot 1.5.626.8 and tested scrolling and still experienced the issue.
    • I have tested scrolling in Chrome and it works fine so I don't think this is an issue with Sierra or my mouse.
    • In case it helps, I'm using a Logitech M310 mouse.
      [/ul]

    Unfortunately, this is a very frustrating issue and makes the browser nearly unusable for me. Hopefully it will be resolved quickly.



  • Update: this morning, I used my laptop at home using a different Logitech mouse and I did not experience the zoom issue. However, now that I'm at work using my M310 mouse, I'm seeing the issue again.



  • Facing the same issue as the others in this thread. Hoping it will be dealt with soon :)



  • Is there any news on this issue? It has beome quite difficult to use vivaldi on mac.



  • I've disabled every mouse and keyboard shortcut in both vivaldi and on the mac. Nothing works. Same, scrolling up craziness. Same, upgraded to Sierra. Same, Chrome works fine. It is making me seasick. Please help.


  • Moderator

    This issue might be related to the issue discussed here. That issue seems to have gotten fixed by the macOS 10.12.1 update that was released yesterday.

    So, does updating to macOS 10.12.1 also fix the issue you have discussed in this thread? (I am assuming the issue is Sierra-only, if that is not the case, please correct me.)



  • It looks like macOS 10.12.1 fixed it. I haven't had a problem since I did the update this morning.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.