Blurry fonts / Direct2d-DirectWrite temporary fix



  • Many people like me can't stand Direct2D rendering or any type of subpixel smoothing, preferring either no AA at all, or standart windows grayscale smoothing that is shipped with W7 and WXP. As everyone knows, Chromium developers chose to drop support for GDI in version 52 because of alleged 'security risks' (haha, yes, tell me more) and forced blurry DirectWrite mess upon all of us. There's no real way to fix this (unless Vivaldi team implements the same thing as Firefox devs did which solved the problem for most people, including even me), but you can do with the following: What do we need to fix fonts: 1) We need a small tool, cleartypeswitch, just download it from http://karpolan.com/software/cleartype-switch/ and install it 2) Create a batch file with the following code: [code]@echo off "C:\Program Files (x86)\ClearType Switch\ClearTypeSwitch.exe" s- c- cd "C:\Program Files\Vivaldi\Application" start vivaldi.exe --disable-remote-fonts timeout 5 "C:\Program Files (x86)\ClearType Switch\ClearTypeSwitch.exe" s+ c- [/code] To launch browser, simply double click on the batch file, and see the results for yourselves. If font's don't change, either paths are wrong or delay is too low. So, if Vivaldi or the switcher are installed on another disk / in another directory, simply change paths to the actual locations. Also, if your PC is slower than mine, you need to increase the delay to something more. Of course, it's not an ideal solution, but it's better than to have your eyes slowly leak out of the sockets.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.