[Solved] Webrtc setting stuck version 1.4.589.29



  • Has anyone got the privacy->webrtc setting being 'stuck'? I'm on version 1.4.589.29.


  • Vivaldi Translator

    Yes. You are not alone.


  • Moderator

    Works on 1.4.589.29 32bit Windwos 10x64

    Please explain what is failing with WebRTC?


  • Vivaldi Translator

    @Gwen-Dragon:

    Works on 1.4.589.29 32bit Windwos 10x64

    Please explain what is failing with WebRTC?

    You can't uncheck that option.



  • Yes. I know what you're talking about. you can't change that option. as long as I remember, the Chromium Project from which Google Chrome, opera and Vivaldi come, does not allow changing the webRTC setting. it's enabled by default and the only way to "disable it" - kinda - is to use an extension. the Only browser I know that allows to deactivate webRTC natively is Firefox, and you need to go deep into about:config, which is dangerous.
    I don't know how it's going with Vivaldi on the webRTC matter and if this hitbox worked would be great, but I read on a site that the Chromium project does not supports webRTC switching, so even if vivaldi has the option, it will remain activated even if you click it (meaning, what happens now if you try to switch it).



  • I can't uncheck



  • In my case it was uBlock Origin which didn't allow me to uncheck WebRTC option. I disabled this extension and it started to work again.

    Win 7 32-bit, Vivaldi 1.4.589.29.


  • Moderator

    I tested it with vivaldi://settings/privacy/ and Alt+P -> Privacy
    I can uncheck it. And the unchecked stays after restart of Vivaldi.

    If you cant it is strange.


  • Vivaldi Translator

    Well disabling ublock worked for me too. Interesting. I always used ublock but I could uncheck.



  • Probably because uBlock Origin has its own privacy setting "Prevent WebRTC from leaking local IP addresses" and it bypass the Vivaldi setting.



  • @muratservan:

    Well disabling ublock worked for me too. Interesting. I always used ublock but I could uncheck.

    Yes, I'm quite sure I could uncheck the webrtc option in the previously as well but I also remembered ublock's own prevent webrtc option causing an issue by unchecking Vivaldi's own built in webrtc option even when webrtc was active.

    Now it seems that Vivaldi is erring on the side of caution by always leaving the webrtc option checked as long as ublock extension is enabled and whatever the state of ublock's own prevent webrtc option.


  • Moderator

    Please, next time you should test your issues first with a fresh profile or without any activated extensions. We cant guess which extensions you are using and which ones are active.



  • @vbop:

    …Now it seems that Vivaldi is erring on the side of caution by always leaving the webrtc option checked as long as ublock extension is enabled and whatever the state of ublock's own prevent webrtc option.

    I have Vivaldi 1.4.589.29 (32-bit) with Ublock Origin 1.9.4
    I can toggle the WebRTC settings freely in both!?

    Windows 10 Pro 64bit.



  • Better check to see if the webrtc ip address is leaking. I remembered the setting (not sure which one - vivaldi or ublock) not reflecting the state it was showing in the previous version for me when I could still toggle the built in setting.




Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.