Vivaldi keeps forgetting passwords



  • :unsure: When using Vivaldi in a GTK environment like Mate or LXDE, it keeps forgetting my passwords. Only when I manually add a password for one of the pages I use, it seems to reload them. In a Qt environment like KDE Plasma 5, it does not have this issue. It is very annoying to have to keep remembering or checking passwords in FF first to be able to login. Is there something I can do to change this, or is there a master password setting that would solve the problem.? Is this a Webkit issue? I really like the browser, but if I have to keep opening FF every time I use Vivaldi, I could just stick to FF.



  • Make sure that Settings – Privacy – Save Webpage Passwords is selected.

    On KDE, Vivaldi uses the KDE Wallet system to store sensitive data. I use Fedora 24 and previously SELinux complained that Vivaldi was trying to create some file with some permissions that the SELinux policies didn't allow. This got fixed with a recent Fedora update.


  • Moderator

    May be package gnome-keyring is missing on your Linux?



  • @axioma06:

    When using Vivaldi in a GTK environment like Mate or LXDE, it keeps forgetting my passwords. Only when I manually add a password for one of the pages I use, it seems to reload them.

    It's probably no general problem of Vivaldi with Gtk. I use MATE and Vivaldi has no problem with my passwords. Old passwords imported from Opera 12 work as well as those added in Vivaldi.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.