History entries should show full URLs (including fragment identifiers), and a couple of bugs


  • Moderator

    In the attached example, I can't distinguish between the different entries without opening them (mouse hovering does not even show the URL in the status bar). [attachment=4534]ScreenShot2016-09-20at4.35.14PM.png[/attachment] They go to wholly different pages that happen to share a title, or use different fragment identifiers to scroll to different element IDs ("anchors") within the same page: https[b][/b]://html.spec.whatwg.org/multipage/microdata.html#names:-the-itemprop-attribute https[b][/b]://html.spec.whatwg.org/multipage/semantics.html#allowed-in-the-body https[b][/b]://html.spec.whatwg.org/multipage/semantics.html#the-link-element https[b][/b]://html.spec.whatwg.org/multipage/webappapis.html#global-object Finding the one I want (in this case I was looking for a half-remembered nugget of info and I didn't recall which section it was in) is further slowed by the fact that command-clicking on them doesn't work to pop a new tab in the background. Also, if I use the context menu to open an entry in a new tab in the foreground (or open a background tab, switch to viewing it, and switch back to viewing the Start Page tab), the Start Page forgets my history search and I have to re-enter it when I return to that tab. That's counterintuitive, frustrating behavior; merely switching tabs should never, in-and-of-itself, reset or otherwise affect page contents. Attachments: [img]https://forum.vivaldi.net/uploads/attachments/25229/ScreenShot2016-09-20at4.35.14PM.png[/img]


  • Moderator

    Wait for it…



  • We are testing internally a fixed history yet, the complete URL will come.
    please stay tuned …. ;)


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.