How to disable hotkey ALT, which leads to open menu of the browser



  • I am using combination ALT+SHIFT+1 to set english first language of typing. Open menu on pressing ALT for me is annoying. How to disable opening vivaldi menu on ALT? Attachments: [img]https://forum.vivaldi.net/uploads/attachments/86280/Screenshot_1.jpg[/img]



  • It cannot be disabled. However, if you press shift first, then Alt + 1 there is no problem.

    There is also no problem if you don't release the Alt key before pressing Shift.



  • Then every software must be a pain for you, as they all start the window menu when pressing and releasing ALT. Go try it on any other window.



  • @AbFour:
    yes, seems to be a buggy thing - and annoying, too.
    no need to disable ALT, but Vivaldi must certainly do some fine-tuning here.

    example:
    I've got LastPass extension on Vivaldi.
    LastPass usually reacts on hotkey ALT+w by default in any other browser I tested, but Vivaldi messes things up.



  • Please add the option to disable openning menu on Alt. Really annoying.



  • @xDShot don't press alt alone then. Every Windows program open its menu on alt pressed and released alone. What you are asking to Vivaldi team is to bypass an hardcoded behaviour, it can be done, but at the risk of breaking something else.



  • @iAN-CooG

    Every

    No. Not even all apps use Ctrl+S to save work, for example :)

    Normally it shouldn't open when I switch layout. The problem is that sometimes I press Alt+Shift too fast, but even that I get switching layout instead of openning menu in ALL apps. Only in Vivaldi it opens menu if I press too fast. I checked this behaviour in Firefox. If I simply press Alt, it opens menu, yes. When I press Alt+Shift, it won't, no matter how fast i press. The same for other apps.

    If you are native English speaker, try adding second layout in your system and set switching on Alt+Shift and try switching in Vivaldi and other apps.

    What you are asking to Vivaldi team is to bypass an hardcoded behaviour

    I don't think it's something hard to change.



  • BTW, I'm on Linux, but it seems that it happens for OP in Windows too, so I don't think it's some kind of system stuff...



  • This is "Vivaldi browser for Windows" subforum, of course I assume we are talking about Windows behaviour in here.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.