Spotify Web Player wants Flash installed after the 1.4 update



  • Sooo, today I've installed the 1.4 update and Spotify Web Player suddenly started giving me 'must install Flash in order to work' message. Yesterday, on 1.3, everything worked like a charm. I thought that Flash support was inside Chromium? Attachments: [img]https://forum.vivaldi.net/uploads/attachments/62917/spotifyflash.PNG[/img]



  • Hi there,

    Do you have any problem playing video on Youtube or other sites?

    After updating to the newest Vivaldi 1.4, I have problem playing video on Youtube, twitter, etc.



  • There are two vivaldi:flags that may affect this: software rendering list, and hardware-decode. For all I know, there may be more, but try one or both of these.

    First, though, just check your menu/tools/plugins to make sure flash player is listed and enabled.



  • I can only confirm that works for me with 1.4 stable, win7 32bit, flash 22.0.0.209



  • Okay, I did what you told me to do, nothing worked. And I think I didn't make myself clear; I don't have Flash installed, nor did I have on Vivaldi 1.3, and the Web Player managed to work. I'd rather still use Vivaldi, without having to install this relic of a fallen ancient civilization or other browser. Do you think this can be helped or am I missing something?

    Cheers!



  • Developers are investigating and working on the bug. There are only a small minority of systems affected, but backstage, at least one hardware configuration that has the problem has been identified, and work is ongoing.



  • I can confirm that this is happening, and it wasn't a problem for me before. Can we look for it in the changelog in the future?



  • It gives me that message with Vivaldi, Firefox, and MS Edge without Flash enabled.

    I don't enable/install Flash because I don't want a program that has over 300 vulnerabilities found and patched per year on my computer and exposed to web sites. It's just not safe enough to justify having around.

    At this year's Pwn2Own, they successfully attacked Chrome, but it required four vulnerabilities. 1 in Chrome, 1 in the Windows kernel, and 2 in Flash. If the user had Flash disabled, it wouldn't have worked.

    So much for "We can make it safe to use with Chrome.". Bleh. I hope Vivaldi never integrates it.



  • @BaronHK:

    I don't enable/install Flash because I don't want a program that has over 300 vulnerabilities found and patched per year on my computer and exposed to web sites. It's just not safe enough to justify having around.

    I have yet to see a single person affected by a flash player vulnerability.

    99.9% of the real world flash player related issues are related to "social" hacking, where the users are fooled to download a fake flash player installer.

    Personally I'm not going to install the flash plugin on a server or a client machine dedicated to very sensitive roles, but on a normal user's PC flash videos just works way better than HTML5 and, unlike the latter, can be easily enabled and disabled at will, sparing data on limited data bundles and computational power on lower end PCs.

    Just to be clear the above is my personal experience and opinion, hand has nothing to do with any Vivaldi official position.



  • I have the same issue with youtube , html5 player does not work …

    After many testing to try resolve the issue it seems to be linked to hardware acceleration, i used to have vivaldi launched with " –disable-gpu " command line … after some tests removing this command allows me to play youtube videos in html5 ...

    Never had a problem before an upgrade of vivaldi some times ago, not sure how to bypass this for now, i don't want the gpu acceleration on vivaldi and still want to get html5 player working on youtube ...

    Thanks

    Edit: using the x64 version of the dev branch 1.4.589.4 but happens since a couple of builds.



  • BTW, I had the problem with YouTube HTML5 player not working and sometimes falling back to Flash (and sometimes throwing an error instead) and in my case it was due to having HW acceleration disabled via this semi-hidden setting:

    vivaldi://chrome/settings/search#hardware

    Re-enabled and it seems to fix the problem.



  • Thank you, I checked and this setting was enabled, had difficulties to find it at start as apparently launching the browser with –incognito command does not displays this page for this setting

    If I disable it i end up with videos not working on youtube, same result as launching the browser with –disable-gpu command …

    Problem is that i don't want the browser to use the hardware acceleration, at all , my cpu is fast enough to take care of this without having my gpu frequencies bumping each few seconds up and down for nothing like it is the case with most gpu accelerated stuff, no gain just annoyances imo.

    With Opera Browser –disable-gpu still works fine of youtube so it must be something internal to Vivaldi and how it uses hardware acceleration for videos decoding.

    Thanks



  • Today's update seems to have fixed the problem, html5 work again with disable-gpu switch enabled :)

    Thanks a lot for the fix.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.