Window Not Surfacing



  • When Vivaldi 1.4.589.2 (Developer Build) is covered by another window and then sent a URL to be opened (e.g., from Alfred, OrgMode, DEVONthink Pro, or some other application), the window doesn't raise to the front and requires a click on to surface it. This is in the latest El Capitan and happens consistently.


  • Moderator

    I'm not able to reproduce the issue on my systems (not even with Alfred, which you explicitly mentioned). Only if I minimize the Vivaldi window to the dock or put Vivaldi into full screen mode before switching to another application does Vivaldi not bring the window with the sent URL to the front.

    Is there anything special about your setup (e.g., window manager, multiple monitors, or something like that) that could be required for the issue to surface?



  • Nope, nothing special. Just an early 2015 13" Retina MacBook Pro.

    But to add to the oddity, I've been running Vivaldi fullscreen in its own Space and when I forward a URL to it, it goes to the Space where I originally launched it rather than the Space where it's now fullscreen. When I ⌘-TAB, it shows Vivaldi in the first slot but I either have to access it from there or swap over to its occupied Space.


  • Moderator

    Yes, there are a few issues left with full screen mode. Does the original issue only happen you work with Spaces and or full screen mode?



  • It happens when Vivaldi's just one of many windows in the default Space, too. See also: https://vivaldi.net/en-US/forum/vivaldi-browser-for-mac/12026-browser-does-not-come-to-front-when-opening-link


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.