Page load with no indicator



  • I frequently have times that I'll click on a link that isn't a download link there is no indication of waiting for the page or other indicator. Shortly after clicking I'll see the address bar change color and do a progress across the bar. However, sometimes I find the time delay is so long I'm not sure if I clicked it properly or what may have happened. Is this normal behavior? I'm used to Chrome and Firefox showing something from the moment I click on a link. Windows 10, Vivaldi 1.3.551.38 32bit. (as a side note, I experienced this when submitting this post.)


  • Moderator

    @DrWho:

    I frequently have times that I'll click on a link that isn't a download link there is no indication of waiting for the page or other indicator. Shortly after clicking I'll see the address bar change color and do a progress across the bar. However, sometimes I find the time delay is so long I'm not sure if I clicked it properly or what may have happened.

    Is this normal behavior? I'm used to Chrome and Firefox showing something from the moment I click on a link.

    Windows 10, Vivaldi 1.3.551.38 32bit.

    (as a side note, I experienced this when submitting this post.)

    It's behavior that's "normal" for the way Vivaldi is designed right now. Developers have not yet settled on the best way to make it better.



  • For me, I watch the "reload current page"-button.

    In most cases it changes to the "stop loading"-button (i. e. an x-shaped cross) when you clicked (properly) on a link or a button of the web-page.
    So,if nothing happens but the "reload current page"-button changed its appearance to the "stop loading"-button, then I know for sure that there is some background activity in order to load the new page (or perform the desired action) :)

    Hope, this "work-around" works for you too



  • Thank you. I never noticed that before.



  • Yay for Lucius!



  • @DrWho:

    I frequently have times that I'll click on a link that isn't a download link there is no indication of waiting for the page or other indicator. Shortly after clicking I'll see the address bar change color and do a progress across the bar. However, sometimes I find the time delay is so long I'm not sure if I clicked it properly or what may have happened.

    Is this normal behavior? I'm used to Chrome and Firefox showing something from the moment I click on a link.

    Windows 10, Vivaldi 1.3.551.38 32bit.

    (as a side note, I experienced this when submitting this post.)

    Vivaldi UI Customisations- loader in tab



  • Must be blind but where do i find this "reload current page"-button? Looked and looked, but can't find it. TIA


  • Moderator

    @douglas9:

    Must be blind but where do i find this "reload current page"-button? Looked and looked, but can't find it. TIA

    It's the symbol to the left of the "Home" icon next to the addressbar. A partial (apx 270 degree) circle with an arrow at the end of it is the "reload current page" button. When that converts to an "X", meaning a page is loading, that is the "stop loading" button. As soon as Vivaldi begins to try to load a new page, that button changes from the circle-arrow to an X.



  • I hope that a future version can replace this with an animation as it's not clear for new users. Thanks!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.