Vivaldi Snapshot 1.3.582.3 crashes when using Youtube



  • After downloading the latest snapshot, Youtube stopped working properly. It will usually not load the videos. (An error occurred. Please try again later.). It might load after refreshing the page a few times. If I go into fullscreen, the browser will crash if I press ESC to exit fullscreen, but not if I exit fullscreen by pressing the Exit full screen button to the bottom right.



  • Yep, I have the same issues. It's not only Youtube that makes Vivaldi quit unexpectedly btw, every video I tried does. Press esc and you're done… And this keypress is so common to me, that I do it automatically and subconsciously. I can't stop myself doing it.

    Additionally to this problem some shortcuts stopped working too. Apparently Vivaldi accepts my German keyboard layout when typing normally, but when I use shortcuts it suddenly thinks my keyboard is QWERTY. Both issues are so annoying that I actually started using Opera stable again for the first time in over a year. Will be waiting for the fixes patiently to get back to Vivaldi. Can't be annoyed to install and setup stable Vivaldi tbh, when I have a perfectly working browser just sitting there waiting for me.


  • Moderator

    Do you happen to still have Adobe Flash installed on your system? I am asking because there is a very recent bug report (VB-20886) about crashes when escaping out of fullscreen videos. When I click on the link provided in that bug report for reproducing the bug, I don't get a video, though, but only a notice that I should install Flash.

    The keyboard issue you have described, luetage, is a recent regression from a Chromium update, IIRC. It is tracked as VB-20707, but better not mix multiple issues in one forum thread.

    I understand that these issues are frustrating. If you do feel drawn back to Vivaldi, though, before the issue is fixed, all you have to do is download the stable version and either put it into a different folder or rename the snapshot version. Your existing settings will be used and there is no additional setup required.



  • I have latest flash installed on my system, are you saying you need to install flash to reproduce the bug, and the fix is to uninstall adobe flash? Because that I can't, I happen to need flash still. And the video close is not the worst problem, worse is that html5 videos start only after several reloads and then in bad quality. So you need to 1.Reload till it starts, 2.Change Quality, 3.Make sure you don't press esc or 4.The process starts again. lol

    These are all issues introduced in 1.3.582.3, and nothing has changed for the latest 1.4.xxx release from a few days ago.


  • Moderator

    I didn't mean to suggest that you should uninstall Flash, I was just trying to get more information on that crash bug. It looked to me like they happen when you escape out of a fullscreen Flash video. If you were experiencing the crashes without Flash on your system that would disproved that hypothesis.

    I don't remember having ever experienced the problem with starting html5 videos that you have described, but I also don't watch a lot of web videos. Do you maybe have a link or two at hand where you experience this problem?



  • Try any html5 video on youtube, it doesn't matter at all which. Just go to the homepage and try the first video you see.
    I did some testing, tried it without any extensions/modifications to the browser enabled and the problems persist. I disabled/enabled flash and widevine but no changes. I also checked out vimeo (that I don't use regularly) and most videos don't load there either. Everything I tried does work on Opera though, so I don't think it's an issue with my system. Also Vivaldi used to work flawlessly too. Don't think we need to discuss this further, I'll just wait for updates.



  • @luetage:

    Try any html5 video on youtube, it doesn't matter at all which. Just go to the homepage and try the first video you see.

    :silly: This is the MAC forum

    Could your keyboard problem be related to
    https://vivaldi.net/en-US/forum/vivaldi-browser-for-mac/14415-vivaldi-inconsistently-recognizing-my-keyboard-layout



  • @luetage:

    Yep, I have the same issues. It's not only Youtube that makes Vivaldi quit unexpectedly btw, every video I tried does. Press esc and you're done… And this keypress is so common to me, that I do it automatically and subconsciously. I can't stop myself doing it.

    There is a fix for this in the latest Snapshot https://vivaldi.net/en-US/teamblog/150-snapshot-1-4-589-4-vivaldi-1-4rc-2

    Note: auto-update for Mac is broken.



  • I know man, I'm following the blog posts….
    What do you mean with "This is the MAC forum"? Weren't you aware of that?

    Anyway, the video problems are now being introduced to Vivaldi stable too, apparently it's a chrome 53 problem. I wonder if chrome 54 will fix this (1.5 snapshots)...



  • @Foz1:

    I had the same issue as purgatori but i seem to have fixed it by enabling "Override software rendering list" in vivaldi://flags/

    This post is from the windows forum. I reset all flags and enabled override software rendering list, restarted Vivaldi and videos are working now. You can check before/after the graphics feature stats in chrome://gpu and you will notice that hardware acceleration is working once more.

    If this helps you head over to this page
    https://vivaldi.net/forum/vivaldi-browser/14094-html5-videos-won-t-play?start=40
    and give Foz1 a big thank you. Really nice find.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.