Debian installer ask to uninstall many packages



  • Hi I try to install deb vivaldi package but it ask to uninstall many packages that I am working with, I do not understand why and what can I do about it. I attach a desktop pic with installer details. I like to try vivladi Regards and thanks for any clue fabian Attachments: [img]https://forum.vivaldi.net/uploads/attachments/22081/vivaldi.png[/img]



  • You running a 32bit debian?



  • sorry I forgot that

    Linux debian 2.6.32-5-amd64 #1 SMP Tue May 13 16:34:35 UTC 2014 x86_64 GNU/Linux

    and gnome desktop



  • Which version of glibc do you have installed (execute command: "ldd –version")? I think, you need >2.15 with Vivaldi like Opera. The dependency based on Chromium.



  • I got 2.11.3 version, but do you think that all the problem is for that library?



  • I think so, but I cant say whether the installation will successfully completed.



  • <em>dpkg -I Vivaldi_TP_1.0.83.38-1_amd64.deb</em> shows dependecies: <br /><pre> neues Debian-Paket, Version 2.0.
    Größe 40899692 Byte: control-Archiv= 7456 Byte.
    1198 Byte, 14 Zeilen control
    12808 Byte, 394 Zeilen * postinst #!/bin/sh
    10178 Byte, 307 Zeilen * postrm #!/bin/sh
    1220 Byte, 42 Zeilen * prerm #!/bin/sh
    Package: vivaldi-stable
    Version: 1.0.83.38-1
    Architecture: amd64
    Maintainer: Vivaldi Package Composer [email protected]
    Installed-Size: 148660
    Pre-Depends: dpkg (>= 1.14.0)
    Depends: gconf-service, libasound2 (>= 1.0.23), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcap2 (>= 2.10), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.9), libgconf-2-4 (>= 2.31.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.28.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.14.3), libpango1.0-0 (>= 1.22.0), libstdc++6 (>= 4.6), libudev0 (>= 147) | libudev1 (>= 198), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3 (>= 1:5.0), libxi6 (>= 2:1.2.99.4), libxrandr2 (>= 2:1.2.99.2), libxrender1, libxss1, libxtst6, ca-certificates, libappindicator1, libcurl3, lsb-base (>= 3.2), xdg-utils (>= 1.0.2), wget
    Recommends: pepperflashplugin-nonfree
    Provides: www-browser
    Section: web
    Priority: optional
    Homepage: https://vivaldi.com
    Description: The web browser from Vivaldi
    Vivaldi browser is made for power users in mind by people who love the Web.
    </pre>



  • Then is the glibc OK (libc6 (>= 2.11)).

    Try the installation in a terminal with apt-get with the parameter -s (for simulation).



  • Hi I just fix everything, thanks, the way was dist-upgrade from squeezy to wheezy and the installer run seetly.
    Thanks to all, for yours comments I did the upgrade.

    The problem start because I have "stable" in my sources.list and debian move on to wheezy and the installer ask to do the upgrade when I try to install Vivaldi…

    I am waiting for final with email options
    Regards

    Fabian


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.