How to unblock a *protocol* (was:program launch) handle?



  • Hello all! TL;DR: I accidentally hit on "Do nothing" (or alike) instead of "Allow application" (or alike) after selecting "Remember my decision" (or alike, lol) and now I can't open a file handler directly from Vivaldi, nor download the file. How to reset this setting? Full version: first of all, a big thank you and congratulations for the Vivaldi team and this community. Have been around the Net since Netscape 1.something on Windows 3.11 and Trumpet Winsock, been an avid Opera user and advocate since at least 4.xxx and part of the crazed horde that went absolutely nuts when Opera announced would give licences for free for a limited time (and later announced to make it permanently free) back in version 5 or 6, I guess. I recently went nuts again when I learned of the first Vivaldi public test releases. Never looked back and it quickly became my new default, long before even beta, this community being my main resource for eventual bugs. So, again, thank you all. I was almost sure I had registered before, but anyway, here's my huge thank you and props. But it also comes with a (potentially hard) question: I was using a site that automatically launches a program to open an URL (specific protocol or something), and dumb me accidentally chose "ignore action" instead of "always allow" after checking "remember my choice". Now I can't open the file or handler anymore: Vivaldi won't even show a message - as expected. Props, it does exactly what it said. :) In good ol' Opera, we had settings under "Downloads" that allowed us to choose which program/action to use for each MIME type, extension, or URL protocol/handler, but I can't find an equivalent in Vivaldi. Already checked the advanced site settings menu at the address field's left corner, selected "Always allow on this site" for both plug-ins and automatic downloads, checked all exceptions, and still no go. Also tried to edit the preferences files, but boy have they become complicated, couldn't figure it out. So, how can I unblock this handler, or undo that setting? Am I missing something or is it an as-of-yet unimplemented feature? Using 1.3.551.28 32-bit on W7 x64. Couldn't find a link to search the bug databases and didn't want to open one without being sure the problem isn't between the keyboard and the chair. That's it for now, and thanks in advance. P.S.: only one real complaint: the user interface is incredibly slow, taking a few seconds to even open the side panels. Any way of improving on this? P.P.S.: Vivaldi Mail? Should I go nuts yet again?



  • If it's a setting you told a website to remember, how about clearing cookies?

    No, too early to get excited about email - but it is on the way.

    What sort of platform are you on? I haven't seen a sluggish interface reaction in over a year. Perhaps it's hardware related.



  • It wasn't a setting for the site, but for Vivaldi - was one of those in-browser messages, similar to the "save password?" or "Keep File/Stay Safe" for when you download a .MSI or .EXE file. It appeared bottom-left on the screen. But just to be sure, logged out, opened the site in a Private Window, checked settings at that site, still the same. Haunted setting.

    Found the speed issue: tried everything I could think of, but it comes down to a very long downloaded files list. Bookmarks are ok, so are notes, in this computer, because they're almost clean. Right now I'm on my notebook: Dell Inspiron 7537, i7-4500, 8GB DDR3-800CL11 with an nVidia 750M 2GB and I guess the slow response on the downloads panel is probably due to sorting, icons etc. Oldest download is from Jun 2015. :blink:

    My desktop is a i5-750 (1st-gen) @2,67Gz, 16GB Corsair DDR3-6667CL9 2-ch and GTX-960, but also contains huge Notes and bookmarks sections - that no one uses, huh? - imported from old Opera, so that's probably why it's so slow on all 3 panels.

    Still trying to figure out the site issue, though..



  • You're describing a setting that I've never seen, and can't understand. It doesn't even sound like it's part of Vivaldi. Can you describe it in any more detail? Can you link the page that activated it?



  • @tulio:

    ….. I was using a site that automatically launches a program to open an URL (specific protocol or something), and dumb me accidentally chose "ignore action" instead of "always allow" after checking "remember my choice". Now I can't open the file or handler anymore: Vivaldi won't even show a message - as expected. Props, it does exactly what it said. :).....

    That sounds more like an OS or AV/Security message. I've also never encountered it in Vivaldi.



  • @Ayespy:

    You're describing a setting that I've never seen, and can't understand. It doesn't even sound like it's part of Vivaldi. Can you describe it in any more detail? Can you link the page that activated it?

    Sure! The site is https://allihoopa.com/ and the message comes after:
    1. selecting a project;
    2. clicking on the "download" icon;
    3. choosing "Open with Reason" (I suppose you must have the software installed for it to work, but you can download the demo).

    Thinking again, I'm gonna temporarily reset my Vivaldi profile folder, go through all of it again and post the screenshots (didn't do it yesterday because I had a number of transfers that I had to leave running throughout the night). BRB.



  • @TbGbe: if it's not from Vivaldi, it's Chromium. I had never encountered it either, until this. :huh:

    Guys, in any case, here are the screenshots. The message in the first image comes after selecting the previous two options in sequence. It's on Allihoopa and I suppose one needs to have Reason 9 installed, even if only the demo.

    If I got it right, looks like the link itself is a protocol (either "reason:" or "ph-reason:") that somehow is handled by Reason, but it doesn't show up on WIndows default protocol associations (Control Panel -> Default Programs -> "Associate a file type or protocol…" nor "Set your default programs"). Couldn't find the protocol handling settings in Vivaldi either.

    Thought to try a text search, but somehow my Vivaldi profile folder is over 1GB and it's not cache. :blink: Guess I'll need to handle this beforehand.
    Attachments:
    ,,



  • Now this was way faster than I thought. Had to uninstall and reinstall Vivaldi: apparently there were 3 versions of the binaries lurking around under Appdata\Vivaldi\Application. 500MB extra space now. :D

    Aaaaaand found it, thanks to Notepad++:
    @AppData\Local\Vivaldi\User Data\Local State:

    "protocol_handler":{"excluded_schemes":{"afp":true,"data":true,"disk":true,"disks":true,"file":true,"hcp":true,"javascript":true,"mailto":false,"ms-help":true,"ms-windows-store":false,"news":false,"nntp":true,"ph-reason":true,"shell":true,"snews":false,"vbscript":true,"view-source":true,"vnd":{"ms":{"radio":true}}}}

    Guessed if I simply took it out, it would ask for confirmation again, so I simply set it to "false" and now it does what I intended: open automatically without confirmation. Phew!

    I guess we need a better way to handle protocol associations. Should I add it to the wishlist yet? :lol: Also, would help if we had line breaks between the settings, unless the intention is indeed to make it unintelligible.



  • Well, they say you learn something every day ;)
    The closest thing to this I have seen would be a request for "magnet" handling, but that was set via O.S./magnet app not Vivaldi.

    I don't think it is intended to be unintelligible so much as NOT user configurable.
    Could certainly add a feature request, but I would think there is already the intention to create a UI interface to those settings.
    Perhaps a feature request would bump it higher in the "list of things to be done".

    Maybe an alternate would be for the Reason 9 software to register the protocol with the OS handler?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.