KB3176493 with wrong/hijacked LAN proxy, could make Vivaldi networkless (VB-20454)



  • After installing this KB, Vivaldi is networkless. Other browsers and internet programs, works. (Vivaldi is not blocked by security softwares) This happen on ALL the versions I have: 1.2 stable, 1.3 stable, 1.3 snapshot. Win10 x64, Vivaldi x64. I'd prefer not to uninstall the update. Any suggestion/workaround/fix is welcome :silly:


  • Moderator

    @Hadden89:

    I installed this KB and after a while, Vivaldi can't connect anymore to the network (neither the router page). Other browsers still works. (Vivaldi is not blocked by security softwares)
    This happen on ALL the versions I have: 1.2 stable, 1.3 stable, 1.3 snapshot.
    Win10 x64, Vivaldi x64.
    I'd prefer not to uninstall the update. Any suggestion/workaround/fix is welcome :silly:

    One of the things that update did was change security for IE and Edge, so adjusting the proxy and/or security settings for these might help. I didn't get that update (I'm on the Windows Anniversary version, so I got KB-3176495 instead on both of my main Windows towers, and it didn't affect Vivaldi functionality at all.)

    Maybe you could force the anniversary update? It seems like a good idea.

    I'm not in a position to check it on either of my 1511 right now, so that's all I can think of.



  • @Ayespy:

    One of the things that update did was change security for IE and Edge, so adjusting the proxy and/or security settings for these might help

    Ok, now seems to work. Wondering why the update did this:
    He put a proxy server for LAN connection for localhost 127.0.0.1:8118: "internet settings" in control panel, desktop one. Unchecked. Now seems fully working again.

    edit
    Sometimes revert to the no-working proxy (in IE internet settings) due proxy hijack leftover malware.
    The funny fact, is that before the update, the hijacking didn't work. However, Malware bytes should have killed it :3


  • Moderator

    Glad you got to the bottom of it.



  • Now works. It seems the scan/fix with Zemana Antimalware has solved the hijacking.
    The rest of the work was made by Ublock blocking some nasty domains which shouldn't be there.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.