Is this what people mean by bad font rendering?



  • The same page in Vivaldi and IE look very different on my computer. Obviously IE looks much better (even though it's anti-aliased - I turn all font smooting, Clear Type etc. off as I don't like it) and Vivaldi looks awful. This isn't just with the 1.3 update, Vivaldi has always looked like this for me. Is this what people are talking about at the moment - the DirectWrite flag etc. - or is that something different? And any idea how I can improve font rendering in Vivaldi? [attachment=4252]font_vivaldi_1.3.png[/attachment] [attachment=4253]font_ie_11.png[/attachment] Attachments: [img]https://forum.vivaldi.net/uploads/attachments/18381/font_vivaldi_1.3.png[/img],[img]https://forum.vivaldi.net/uploads/attachments/18381/font_ie_11.png[/img]



  • Does anyone else see this kind of text rendering or is it just me?


  • Moderator

    My Vivaldi 1.3 does not show such strange font display on Windows 10x64.

    Is that on all pages with Vivaldi?



  • "Clear Type etc. off as I don't like it"
    too bad because you have to turn it on, some time ago chromium dropped GDI render
    there are many discussion about it, many people are frustrated by this
    https://groups.google.com/a/chromium.org/forum/#!topic/chromium-dev/WzivQg8_drw


  • Moderator

    That sort of font display probably means your system doesn't have the font that Vivaldi is trying to use.

    You might want to try reinstalling Windows font package. http://www.withsteps.com/3483/windows-10-pro-default-fonts-download.html



  • or it could be street slang, like Bad means good now (in the old days, wicked) or even sick? So if you have bad font rendering do you mean good? :)



  • Man, that's just horrible. Pretty sure that's not caused by a missing font. That wouldn't be causing it to look this horrendous, that would just cause the browser to use a different font, but still very similar in general look to how IE renders the page. This looks like GDI font rendering with font antialiasing and glyph grid fitting completely disabled.

    I'd start by trying a completely new and clean profile to make sure it's not some leftover setting in the current profile causing the havoc.

    Then again you say you turn off all font antialiasing. That's not a wise decision as it's not really an option Windows (and fonts themselves) expect nowadays and you can get some pretty bad results, possibly even something like this.



  • Try to delete file ChromeDWriteFontCache in Vivaldi profile at %LOCALAPPDATA%\Vivaldi\Userdata\Default\

    Thanks to Gwen-Dragon for this reply to me back in May



  • I haven't tried this fix but a user posted it on this forum a while ago:

    _My work-around is:
    Add "–force-device-scale-factor=1" to the Vivaldi short cut.
    Set the "Appearance" / "User Interface Zoom" to the same scaling as the Windows (DPI) scaling.
    Set the "Webpages" / "Default Webpage Zoom" to the same scaling as the Windows (DPI) scaling.
    _


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.