Google Search settings



  • Vivaldi has a strange behaviour when I change Google Search settings. I don't like Google Instant. So, every time I search something in Google, I disable it. After the first search, I click on the cog (on the right upper corner) and select "Search settings". And then I select "Never show instant results". After I save my preferences, the other bowsers redirect me back to the search results page. With Vivaldi, what I get is a blank page.


  • Moderator

    I've seen a few bug reports about blank pages for different search engines that were filed very recently. To me, it looks like what you are describing is caused by the same issue. If you see in the changelog of a new snapshot that a problem with blank pages and search engines has been fixed, but the issue you are describing is still present with that newer version, it would be great if you could let us know.

    In the meantime, I would suggest not using the Google web page for doing Google searches, but doing them right from Vivaldi. For instance, you can hit Cmd-E and then type "g abc" to do a Google search for "abc". Alternatively, you can search straight from the address bar.



  • Thank you for the reply.
    Yes, the issue is happening with the latest stable version (1.3.551.30).
    I always do the search from the address bar. The problem with the blank page happens after I change the Google Search settings and save my preferences. Instead of redirecting me back to the search results page (just like all other browsers do), Vivaldi gives me a blank page.


  • Moderator

    What I meant is that the reports about issues with blank pages for search engines under certain circumstances have only appeared very recently and that this bug is not even fixed in the internal test builds. What I was asking you to do is to look at the changelogs of future snapshots to see if they mention that the issue with blank pages for search engines has been fixed. If that is the case but you still experience the issue, then it would be great if you could let us know that your issue still persists.

    If you do your searches from the address bar anyway, then I don't understand why you need to change the Google Instant settings on the actual Google web page, though. Oh, I guess it's for refining searches. How come though you regular need to turn off the Instant feature, is that setting not saved in a cookie or so? Pardon my ignorance, I try to avoid Google as much as possible because I'm not a huge fan of how they utilize personal data. That's why I primarily use DuckDuckGo.



  • Thank you once again for you reply.
    I like to clean my browsing data (history, cookies, etc.) at least once a day. That's why I need to change Google Search settings.
    I understand your concerns about Google politics and I agree with you. However, I still use Google Search because it gives me much more results than DuckDuckGo.
    I'll be watching the future versions of Vivaldi (including Snapshots) to see if the issue has already been solved.
    Thanks.



  • Problem solved with version 1.3.551.37 (Snapshot).
    Excellent work!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.