H264/mp4 fails on Vivaldi 1.3/Fedora 24



  • Good day, Happy to see the release of 1.3, many awesome improvements. One bug that is still sticking for what appears to be Fedora 23/24 users is that libffmpeg.so is still being rejected or not loaded by Vivaldi. - Fail h264/mp4 test on basic test sites - Fails on twitter/vine videos "Browser does not support video playback" error - Tried using the stock /opt/vivaldi/lib/libffmpeg.so that is included in 1.3 - Tried copying libffmpeg.so from chromium-codecs-extra package from another linux distro into /opt/vivaldi and /opt/vivaldi/lib (used to work till 1.2 release) - Tried on different hardware just incase of a decode issue (nvidia and intel) - tried to modify vivaldi-stable to force load the libffmpeg.so with no error, but didn't resolve the issue - Installed chromium-libs and copied libffmpeg.so to /opt/vivaldi/lib and /opt/vivaldi (alt path worked before) - Installed ffmpeg and ffmpeg-devel, but there is not a libffmpeg.so to link with I'm at a lost for what logs or screenshots I could gather to help assist in the issue. -CL



  • Fixed my own problem… The two packages on Fedora for chromium-libs and ffmpeg* don't have h.264 and mp4 support due to licensing restrictions. The fix was to fire-up my VM from another distro and copy over the libffmpeg.so after accepting the licensing terms on that machine. More info can be found here


  • Moderator


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.