Can't turn off WebRTC



  • When I click the checkbox for disabling WebRTC broadcasting of IP, nothing happens.



  • Are you using the WebRTC Leak Prevent extension?

    Disable the extension and you should be able to click the checkbox.



  • Thanks… I was having the same problem, and disabling that extension fixed things so the box could be checked. Because the WebRTC-blocking extension I'd been using (WebRTC Network Limiter) doesn't appear in the extension bar, I had forgotten it was there.



  • I just upgraded to 1.8, and cannot uncheck the WebRTC box. I couldn't even uncheck it BEFORE I got the WebRTC leak prevent extension. So I went and got the extension, tried to uncheck while enabled and disabled, and it will not uncheck in either case.

    Other boxes uncheck just fine, just not that one. I was on 1.7 and don't remember if this box was checked or unchecked before the update, unfortunately.

    Any suggestions?

    EDIT: Please disregard. I found another thread that mentions the uBlock interference, so I'm trying that now. Sorry for the trouble!


  • Moderator

    As i remember some extensions block the change of Vivaldi's privacy settings related to WebRTC.


  • Moderator

    @Gwen-Dragon: Agrees with my recollection. Option is selectable unless you install an extension that takes it over - then you can no longer select it.


  • Vivaldi Translator

    2 famous extensions uBlock0 (already mentioned) & Privacy Badger has toggle for WebRTC on/off. uMatrix also has it but it's settings structure probably not easy to recognized by non tech savvy.

    Rule of thumbs; some extensions categorized/advertised as security or privacy concern could have that option.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.