Navigation bug - very annoying!!!!!!



  • I've been trying to work out why Vivaldi ends up randomly going back pages, and worked out it's not so random And I can now reproduce this on my Mac Pro running OS X 10.10.5, this is the single most annoying problem I have with Vivaldi along with poor font rendering on Windows stops me moving over 100%: 1. Open a new tab in Vivaldi 2. Visit www.wordpress.org (any website will do but for testing purposes only) 3. Now click through to few pages so the 'back page' icon is enabled' To reproduce the bug: 1. Right-click on any white space, no links, buttons etc...so the Vivaldi drop-down menu is displayed 2. Now double left-click on the page and not on the Vivaldi drop-down menu I am finding Vivaldi will execute a back-page Note: This happens on other website also.


  • Moderator

    Thank you for the report. Good news: I was able to reproduce that bug with 1.2 stable, but not with the current internal test build that I am primarily using. That means that the bug likely got fixed already some time ago.

    So you now have two options to get rid of this bug:
    [ol]

    • You wait for 1.3 stable to be released, which will hopefully not be too far away.
    • You grab the most recent snapshot release from here.
      [/ol]


  • Hi,

    I'm using Vivaldi 1.3.551.21 (Developer Build) (64-bit), I think this is the build in the link you gave. But I will give it a go.

    I've also noticed the first right-click tends not to work, I right-click again and the drop-down menu appears the issue can be reproduced.

    BTW: I'm using a mouse and not a touch pad.


  • Moderator

    After a bit of fiddling around I figured out what the issue is: You are accidentally triggering the "Rocker Gesture" for history back. You can turn it of at "Vivaldi Preferences->Mouse->Allow Rocker Gestures".

    The reason why I couldn't reproduce it in my current internal build is because that is my main install in which I have mouse gestures generally disabled.



  • Thank you.

    I would suggest you reconsider this gesture, maybe disable it by default. People trying the browser for the first time may not get the UX they expect if the 'rocker gesture' is accidentally triggered. The 'Rocker Gesture' does not exactly sound like an option a new user would think; 'Ah! if I switch that off the problem will go away'.

    I had the same issue with Opera, the reason why I didn't (ever) stick with Opera, Nice browser but utterly annoying and unexpected UX.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.