Instagram videos



  • Hallo, instagram videos/vine just dont play :( but work fine with chrome, i think is something with h.23


  • Moderator

    Yes? Well, give us more…
    Which URL of video? Which Windows? Which graphics card GPU? Which Vivaldi?



  • @Gwen-Dragon:

    Yes? Well, give us more…
    Which URL of video? Which Windows? Which graphics card GPU? Which Vivaldi?

    any video instagram, just dont play. for example:
    https://www.instagram.com/p/BIwtyyvjB49/

    windows 7 32 bits
    vivaldi 1.2.490.43
    onboard card 92945g expresshttps://www.instagram.com/p/BIwtyyvjB49/

    vivaldi 1.2.490.43

    happen the same with opera but work with chrome…



  • @luucasalves:

    any video instagram, just dont play. for example:
    https://www.instagram.com/p/BIwtyyvjB49/

    windows 7 32 bits
    vivaldi 1.2.490.43
    onboard card 92945g express

    happen the same with opera but work with chrome…

    Works for me - Win 10 Pro 64; Vivaldi 1.2.490.43

    (Although I had to disable my ad-blocker extension, Ublock Origin).

    A quick check if extensions are interfering is to test with a new profile.

    Check Help/About for the path of your Profile
    Close Vivaldi
    Rename the Folder - e.g. Default.Saved

    Restart Vivaldi (a new Default folder will be created automatically) and check your instagram videos.
    If they now work, install each extension individually and retest after each

    Note: you can copy the Bookmarks files from the Default.Saved folder to the new Default folder.

    Another possibility, as you have on-board graphics, try disabling hardware acceleration
    chrome://settings/search#hardware



  • @TbGbe:

    @luucasalves:

    any video instagram, just dont play. for example:
    https://www.instagram.com/p/BIwtyyvjB49/

    windows 7 32 bits
    vivaldi 1.2.490.43
    onboard card 92945g express

    happen the same with opera but work with chrome…

    Works for me - Win 10 Pro 64; Vivaldi 1.2.490.43

    (Although I had to disable my ad-blocker extension, Ublock Origin).

    A quick check if extensions are interfering is to test with a new profile.

    Check Help/About for the path of your Profile
    Close Vivaldi
    Rename the Folder - e.g. Default.Saved

    Restart Vivaldi (a new Default folder will be created automatically) and check your instagram videos.
    If they now work, install each extension individually and retest after each

    Note: you can copy the Bookmarks files from the Default.Saved folder to the new Default folder.

    Another possibility, as you have on-board graphics, try disabling hardware acceleration
    chrome://settings/search#hardware

    i just install vivaldi, no extensions… disable hardware accelaration but dont work too :(



  • I love Instagram too, but all the time some trash follows me, usually it is just a regular spam. I've found https://spamguardapp.com/dashboard, it solves this problem, may be it will be useful not only for me.



  • Same problem with most videos from 1.10, plays for 1-2 seconds, then stops abruptly.
    Apart with youtube, Vivaldi has become unusable for most video sites.



  • No problem here! I've never had problems with videos on Vivaldi until this very moment!



  • Why are you still on Vivaldi 1.2? I'd try to update to 1.10 first.



  • for me videos of instagram plays, but sometime videos play for few seconds then stops, i have to cancel it once then play it again to play properly



  • @luetage said in Instagram videos:

    Why are you still on Vivaldi 1.2? I'd try to update to 1.10 first.

    They aren't, they just bumped an old (related) thread.



  • I am having this same issue, I've tried a few things over the past few days but nothing seems to work, I had to force always allow to even get it to play facebook integrated videos but that doesn't work for instagram for some reason.

    Vivaldi 1.13.1008.34 (Stable channel) (32-bit)
    Revision b6fccac0c52b4c99d9e782ecd46c3537fbea1b28-
    OS Windows (10 Pro 64bit)
    JavaScript V8 6.2.414.43
    Flash 28.0.0.126

    Edit: I'm now running the 64bit verion on the the browser along with 64flash but that hasn't changed anything.


  • Moderator

    @stedmana Give us a public URL (without any login needed) for this issue.



  • I'm assuming you mean a link to an instagram video? I could pick any video on instagram and it won't load, I can check these urls in any other browser it seems and its flawless, again vivaldi seems to work fine with facebook videos and reddit but instagram just will not work.

    https://www.instagram.com/p/BYPAMOJAfNy/?taken-by=audi_of_nz

    https://www.instagram.com/p/BYLum29Awn4/?taken-by=mayjflute

    https://www.instagram.com/p/BdNWzFggT0G/?taken-by=birdbee0705

    I just picked some random ones, the videos present their front image and the click to play icon, but when I click on it nothing happens the image stays the same in vivaldi


  • Moderator

    @stedmana All 3 linked videos play fine on my Windows 10 x64 Pro with 1.13 Stable and 1.14 Snapshot.



  • I installed the media feature pack you linked. unfortunately it only made things worse it now won't play facebook videos either, I then uninstalled both flash and Vivaldi and then reinstalled it and re enabled allow all and still no fix.

    I am using windows defender and everything works with other browsers. I made sure for always allow in the browser.

    I had a look in chrome://flags/ to see if there was anything in their that might be fix it but I couldn't find anything.

    When I get round to doing another fresh install of windows at some point (I already did one recently) I'll try again.

    Will Vivaldi eventually feature the same integration that official chrome has when it comes to those sorts of features?


  • Moderator

    @stedmana said in Instagram videos:

    I installed the media feature pack you linked. unfortunately it only made things worse it now won't play facebook videos either, I then uninstalled both flash and Vivaldi and then reinstalled it and re enabled allow all and still no fix.

    Ouch, i never expected that this will make it worse.
    Di you try a Windows Update and a update for you graphics card drivers?

    I had a look in chrome://flags/ to see if there was anything in their that might be fix it but I couldn't find anything.

    Any hints in first section after opening vivaldi://gpu ?

    Second try: can you please test videos by starting Vivaldi with command line:

    • Start cmd.exe
    • Goto program dir (with the vivaldi.exe)
    • Type vivaldi --disable-gpu
      and hit Enter

    When I get round to doing another fresh install of windows at some point (I already did one recently) I'll try again.

    Something with Windows codecs may be broken.
    May be open Windows Optional Features, remove Windows Media Player and re-add Windows Media Player could help.

    Will Vivaldi eventually feature the same integration that official chrome has when it comes to those sorts of features?

    Same? Not in near future. Vivaldi can only use free codecs and the Windows installed as licence issues block intregration like in Chrome.



  • @gwen-dragon

    Somehow Its back to how it was today, everything works except Instagram again.

    as to vivaldi://gpu

    All flash is hardware accelerated although there are a fair few "Problems Detected" but it seems unrelated

    I'll try the CMD command



  • Turns out I was wrong It loaded what I thought was flash on reddit but then I check again with facebook and it wouldn't play back anything on there.

    I tried cmd and it launched in software only but it didn't help.

    I'll try re adding media player



  • I tried un/installing the media player in optional features, I even restarted the machine both times just to be sure, still nothing.

    I think I'll just leave it for now, I'm suspecting its just something wrong with my current OS instance

    thanks


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.