Cannot play HTML stream (Twitch)



  • I am using Vivaldi as my main browser and everything worked perfectly until I tried to play some live stream content on TwitchTV. It just shows a black screen. I read on the forums about this and most people had problems with FlashPlayer. I doubt this is the problem as Twitch runs for a couple of months on HTML5 only. Or, it should, at least. Any suggestions? Attachments: [img]https://forum.vivaldi.net/uploads/attachments/84369/twitch.PNG[/img]



  • No, it's flash in the background with a html5 face. They are testing html5 for turbo users if i remember correctly. So you need flash for now.

    edit: HTML5 Video Player Beta



  • its weird because they definitely have html5 player enabled for non beta users, it just crashes/bugs out (console shows something about uninitialized variables?) almost immediately after starting to play
    I dont have flash, and twitch streams DO start to play 'just fine' …for a couple of seconds. Scroll bar shows NaN as seek time, there is no way of setting stream quality and it crashes after at most ~10 seconds going black, but it does try to play with no flash :o



  • Hi, I can play all streams without problems.
    I am on Linux so cant help but just for info twitch.tv is working fine even when I disable Flash in plugin settings.
    I have no twitch account.

    Cheers, mib



  • @mib2berlin:

    Hi, I can play all streams without problems.
    I am on Linux so cant help but just for info twitch.tv is working fine

    can you fast forward? some streams play fine for me with no flash, but seek bar is empty or has NaN for timestamp



  • I see message "Couldn't load plugin". Im using uBlocker and Ghostery with option to block all trackers. I try to pause blocking and reloading page but again i did see that message. I have this problem also at Mixcloud and some sites like imgur. Using Windows 7 64 bit System and Vivaldi 1.3.551.30 (Stable channel) (32-bit)
    Revision ec1fa47e9941592fc4783e7c53ea5291c667df58



  • @rasz_pl:

    its weird because they definitely have html5 player enabled for non beta users, it just crashes/bugs out (console shows something about uninitialized variables?) almost immediately after starting to play
    I dont have flash, and twitch streams DO start to play 'just fine' …for a couple of seconds. Scroll bar shows NaN as seek time, there is no way of setting stream quality and it crashes after at most ~10 seconds going black, but it does try to play with no flash :o

    Nice to know. Maybe twitch changed it in the last weeks and it may also depend on viewers country and the stream one watches. Need to try it myself.



  • @ZzozZ:

    I see message "Couldn't load plugin". Im using uBlocker and Ghostery with option to block all trackers. I try to pause blocking and reloading page but again i did see that message. I have this problem also at Mixcloud and some sites like imgur. Using Windows 7 64 bit System and Vivaldi 1.3.551.30 (Stable channel) (32-bit)
    Revision ec1fa47e9941592fc4783e7c53ea5291c667df58

    I also have ublock and ghostery on Vivaldi 1.3.551.30 (Stable channel) (32-bit).
    The "previews" on Mixcloud work fine (no disabling needed).

    Some tests you can try to check you have all codecs etc.

    https://www.youtube.com/html5
    www.quirksmode.org/html5/tests/video.html.
    demo.castlabs.com (to confirm that DRM is working)



  • www.youtube.com/html5 results:
    ✓HTMLVideoElement
    ✓ H.264
    ✓ WebM VP8
    ✓ Media Source Extensions
    ✓ MSE & H.264
    ✓ MSE & WebM VP9
    The HTML5 player is currently used when possible.

    I can open youtube videos, playlists and etc. All of the elements work ( time slider, volume slider, buttons ).

    www.quirksmode.org/html5/tests/video.html results:
    On chrome 9 evrything is green Yes. Also i can play all of the videos and slide them as well.

    demo.castlabs.com results:
    I can play all of the videos! All sliders and buttons work great :)



  • @ZzozZ:

    www.youtube.com/html5 results:
    I can open youtube videos, playlists and etc. All of the elements work ( time slider, volume slider, buttons ).

    www.quirksmode.org/html5/tests/video.html results:
    I can play all of the videos and slide them as well.

    demo.castlabs.com results:
    I can play all of the videos! All sliders and buttons work great :)

    Are you sure you have an HTML5 problem?
    Seems more likely to be Flash Plug-in problem
    Does Vivaldi Help/About show Flash is installed?



  • @TbGbe:

    Are you sure you have an HTML5 problem?

    No

    @TbGbe:

    Seems more likely to be Flash Plug-in problem

    I don't have Flash installed on my PC

    @TbGbe:

    Does Vivaldi Help/About show Flash is installed?

    Vivaldi 1.3.551.30 (Stable channel) (32-bit)
    Revision ec1fa47e9941592fc4783e7c53ea5291c667df58
    OS Windows
    Blink 537.36 (@ec1fa47e9941592fc4783e7c53ea5291c667df58)
    JavaScript V8 5.2.361.49
    Flash 22.0.0.209
    User Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.117 Safari/537.36 Vivaldi/1.3.551.30



  • @ZzozZ:

    I don't have Flash installed on my PC

    Vivaldi 1.3.551.30 (Stable channel) (32-bit)
    Revision ec1fa47e9941592fc4783e7c53ea5291c667df58
    OS Windows
    Blink 537.36 (@ec1fa47e9941592fc4783e7c53ea5291c667df58)
    JavaScript V8 5.2.361.49
    Flash 22.0.0.209
    User Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.117 Safari/537.36 Vivaldi/1.3.551.30

    That says that you do have Flash installed!?
    However, it may not be the PPAPI version of Flash, check Tools/Plug-ins and click the "details" link near the top.
    https://help.vivaldi.com/article/install-flash-player-for-vivaldi

    Another "workaround" for other users has been to change the Hardware Acceleration setting.
    See chrome://settings/search#accel



  • Adobe Flash Player - Version: 22.0.0.209
    Shockwave Flash 22.0 r0
    Name: Shockwave Flash
    Description: Shockwave Flash 22.0 r0
    Version: 22.0.0.209
    Location: C:\Program Files (x86)\Google\Chrome\Application\52.0.2743.116\PepperFlash\pepflashplayer.dll
    Type: PPAPI (out-of-process)
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl

    At the top right corner i have chekbox Always allowed to run. That chekbox is empty ( not cheketd ).
    In vivaldi://settings/search#accel I have chked Use hardware acceleration when available



  • @ZzozZ:

    Location: C:\Program Files (x86)\Google\Chrome\Application\52.0.2743.116\PepperFlash\pepflashplayer.dll

    In vivaldi://settings/search#accel I have chked Use hardware acceleration when available

    So your Vivaldi is using the Flash Player plug-in from Google Chrome.
    I use the one direct from Adobe, but do not believe this would be your problem.
    Otherwise it's all the same settings as mine (although I'm on Win 10 64 - not Win 7 64)

    As my last thought on this, have you tried to DISABLE hardware acceleration?

    chrome://settings/search#accel



  • @opaque:

    Need to try it myself.

    Uuh, I just disabled the flash plugin (using chromium on linux) reloaded a stream page without restarting the browser: at first it asked me to enable flash to play the stream, but after another reload it somehow started to play the stream. So, html5 is working but there seems to be some kind of branching which prefers flash. …And trying a twitch stream or a vod with latest stable 32bit-vivaldi on windows works too (without any tweaks) :woohoo:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.