Can't install Vivaldi any more



  • Hi all, I installed Vivaldi 1.2 and later on the latest 1.3 snapshot. Some things didn't work that well in 1.3 so I decided to uninstall and reinstall 1.2. It seems to install. The short cut icon appears on the desktop and than suddenly it disappears and the program isn't installed. Than I used CCleaner to get lost of all remaining things but it doesn't help. Any suggestions? Robby



  • First uninstall all versions of Vivaldi, then cleaning the registry with CCleaner and after this try to install v1.2 again



  • That's exactly what I did… Doesn't work.


  • Moderator

    Did you make a direct visual check to ensure the prior Vivaldi folders were gone?



  • CCleaner is a BS. I've never liked what it does to the system. If you wanna get rid of leftovers when uninstalling, use GeekUninstaller. It has a 100% free version for personal use. It always removes absolutely everything without damaging the registry, unlike CCleaner.
    Or, you can always perform a manual uninstall, altough if you don't know what you're doing, I wouldn't recommend it.



  • I tried but and cleaned up some residual files. But no luck there. Maybe I didn't find them all.



  • I've looked into Geekuninstaller. Maybe this works when Vivaldi is uninstalled with this program. But in my case when it is uninstalled with the default windows tools, Geek doesn't find the left overs. I did a manual search of the registry and deleted all keys with "vivaldi" in it. This did the trick.

    But after reinstalling 1.2, private browsing is not working.



  • I mentioned to CCleaner to say they have it, but I do not like too, there are better programs of cleaning such as Wise Cleaner, Glarys Utilities or Argente Utilities. But if that does not work Vivaldo after reinstall it clean is rare. Sorry for my english



  • Please, don't suggest any registry cleaner ever. They either do more harm than good, or are completely useless. Installers should be written correctly, that's the solution.



  • @djgtram:

    Please, don't suggest any registry cleaner ever. They either do more harm than good, or are completely useless. Installers should be written correctly, that's the solution.

    Do you have another idea why Vivaldi of Rob don't work then a wrong entry in the registry? Maybe help to restore the system to a date before instaled Vivaldi


  • Moderator

    It's a catch 22. Registry cleaners are, on the whole, dangerous. I have literally had to reinstall Windows after using one.

    That said, something the user did with Vivaldi (probably an extension) corrupted the registry and now Vivaldi can't be properly uninstalled or reinstalled. Extensions are sometimes dangerous. So are registry cleaners. Better to never use extensions in the first place. This is why I am in favor of Vivaldi having enough built-in options in the long run that extension use can be either minimized or eliminated. Extensions cannot be trusted.



  • I suppose it's hard for programmers on a window platform to clean up everything after uninstalling a program. Parts of the program may be used by other programs. But I agree there is room for improvement. Until that time registry cleaning is a necessary evil for non-Linux users I think.

    Still wondering why private browsing doesn't work any more… any suggestions?

    Robby


  • Moderator

    I don't understand the structure of Vivaldi well enough to offer a clue, I fear. I suspect an extension made a registry entry (or two, or five) that hasn't been cleaned, and that is blocking private browsing. Vivaldi in and of itself uses very few Windows registry entries by comparison to many Windows apps, which is one of the reasons why merely cleaning a profile is an almost-universally-successful fix. I wonder if installing Vivaldi as standalone (and not registering it) would make it able to run without glitches? If so, you know for sure that the problem is in Windows registry.

    The only other externality I can think of is 3rd party security software. These are also dangerous to use. They may "protect" your system from foreign threats pretty well, but many nowadays also "protect" your system from installed apps by keeping modules or operations of them from running. Worse still, you can "disable" 3rd party security software, but it continues to run at the "services" level and still blocks normal system functioning. I used 3P virus and malware solutions for 15 years. I no longer do. They cannot be trusted. Instead, I use safe browsing practices and MS built-in security. I've not been infected in five years.



  • You might be right. I can tall the problem started after installing 1.3. Turning back to 1.2 didn't solve it.
    Just to be sure I stopped my virus scanner and firewall, but without success. Than I started windows in save mode. This also didn't help. So I suppose the 1.3 version changed something in the registry. I only use adguard and a spellcheck function but without these the problem persists.

    Lets see what will happen after a few versions of Vivaldi. May be the problem will be solved then. For now Opera will do fine, and there visuals and UI are better than the actual state of Vivaldi. But for the long run I would like to turn to Vivaldi, now Opera is soled to the Chinese. No flame intended to the Chinese people but in some countries the government doesn't respect the integrity of private companies. Opensource code could make Vivaldi a winner I think. (But that's a complete different discussion).

    Robby



  • Hi everyone

    I had the same problem, so I tried deleting the default folder of Vivaldi installation and installing Vivaldi somewhere else, it worked, now I have version 1.4.589.38 and all working fine.

    Hope you find this useful



  • Exactly

    Vivaldi has very little to do with the registry (just the default browser setting, the uninistall infos and little else)

    As any modern multiplatform program it relies to the config folder in \appdata.

    Probably the OP had just some permission messed either in the \appdata ot program files folder.

    In such case just uninstall vivaldi, and move or delete the affected folder, or fix the permissions and ownership.

    The install Vivaldi again.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.