Vivaldi startup with last session



  • For the last time i have been notice that settings with startup with last session didn't work any more. For anyone happen this? I'm using always the last version



  • Same issue


  • Moderator

    Cannot replicate. Please specify Vivaldi version number, platform, and any/all extensions being used.



  • Here is About window content:
    Vivaldi 1.4.589.29 (Stable channel) (32-bit)
    Revision 969d05a1b96c3d055ffe748671732b49fa1bb45e
    OS Windows 7 64bit
    Blink 537.36 (@969d05a1b96c3d055ffe748671732b49fa1bb45e)
    JavaScript V8 5.3.332.45
    Flash 23.0.0.162
    User Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.122 Safari/537.36 Vivaldi/1.4.589.29
    Command Line "C:\Users\uss\AppData\Local\Vivaldi\Application\vivaldi.exe" –vivaldi-standalone --always-authorize-plugins --disable-translate --enable-use-zoom-for-dsf=false --ppapi-flash-path="C:\Windows\SysWOW64\Macromed\Flash\pepflashplayer32_23_0_0_162.dll" --flag-switches-begin --num-raster-threads=4 --enable-smooth-scrolling --flag-switches-end
    Executable Path C:\Users\uss\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\uss\AppData\Local\Vivaldi\User Data\Default
    Compiler MSVC 2015


  • Moderator

    Thank you. Extensions?




  • Moderator

    None of those particularly jump out at me as a likely reason for your problem.

    Refresh your profile and see if that fixes it. If so, re-install extensions one at a time and see if one breaks it.



  • It's been happening to me for the past few versions. I'm on 1.4.589 right now and it always comes up with a blank tab, and I have to reload my X number of tabs from the Trash.

    Vivaldi	1.4.589.38 (Stable channel) (32-bit)
    Revision	afa9b018e32575fcd8f8283755a315804ecf0671
    OS	Windows 
    Blink	537.36 (@afa9b018e32575fcd8f8283755a315804ecf0671)
    JavaScript	V8 5.3.332.47
    Flash	23.0.0.162
    User Agent	Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.148 Safari/537.36 Vivaldi/1.4.589.38
    Command Line	"C:\Users\clint.mayer\AppData\Local\Vivaldi\Application\vivaldi.exe" --no-startup-window /prefetch:5 --always-authorize-plugins --disable-translate --enable-use-zoom-for-dsf=false --ppapi-flash-path="C:\Program Files (x86)\Google\Chrome\Application\53.0.2785.116\PepperFlash\pepflashplayer.dll" --flag-switches-begin --flag-switches-end
    Executable Path	C:\Users\clint.mayer\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profile Path	C:\Users\clint.mayer\AppData\Local\Vivaldi\User Data\Default
    Compiler	MSVC 2015
    


  • I renamed my default folder and launched Vivaldi. The issue was gone. I then deleted the new Default folder and renamed the old one back. The problem is still gone, so I'm not sure what is happening.

    I had one theory that maybe it had to do with using the Signal web app. I have it open most of the time and thought maybe when I closed Vivaldi (it also closes Signal) that maybe that app was being considered the last tab open and that caused it to relaunch with one empty tab. I've tested closing Vivaldi with Signal open, and by closing Signal first. Neither have caused the issue to reoccur.



  • @gruberxx, @kauper, @Omen_20, check in the following Windows registry key:
    [HKCU\Software\Microsoft\Windows\CurrentVersion\Run]
    if you have Vivaldi autostart entry added, something like:
    "GoogleChromeAutoLaunch_6C37C7EBABD1EFDFE3A4F133C617AEE0"=""C:
    Program Files (x86)\Vivaldi\Application\vivaldi.exe" –no-startup-window /prefetch:5"

    It was added by some extension. Remove it and restart Windows - restoring last session in Vivaldi will start to work again.
    It is already reported as VB-22058. Hopefully to be fixed sometime soon, watch out snaphots' changelogs…


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.