@djanci: You can get to that same setting in Vivaldi, by going to chrome://settings/search#pass

If you were to disable and re-enable it there, I guess it's possible that Vivaldi would act differently. Of course it should not be having the problem in the first place, and none of my 14 installs do have the problem.